2010 2011 BMW 5 Series Forum F10
BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read
 

2010 2011 BMW 5 Series Forum F10 F10 Technical Topics Navigation, iDrive, Audio, Video, Bluetooth, Phone, Coding USB port in the center console won't charge iPod
Post Reply
 
Thread Tools Search this Thread
      04-10-2011, 11:16 PM   #1
JPHender
New Member
United_States
3
Rep
12
Posts

 
Drives: 1999 528i, 2011 528i Sport
Join Date: Nov 2010
Location: San Jose, CA USA

iTrader: (0)

USB port in the center console won't charge iPod

I discovered inadvertently that the USB port in the center console does not charge my iPod. Does anyone know it this is normal?

I've had the car for three months now and keep an iPod nano in the console. This past week, every time I tried to listen to the iPod, it would disconnect after one or two songs and hang, like has been reported in other threads. I finally took a look at the iPod this afternoon and found that the battery was completely dead! even though it has been plugged into the usb port continuously. I tried several cables and none charge the iPod. If this is by design, it is a HORRIBLE design. Why doesn't the usb port provide power out for charging???
Appreciate 0
      04-11-2011, 03:10 AM   #2
SpawneyGet
Private
United Kingdom
1
Rep
95
Posts

 
Drives: F10 535d M Sport
Join Date: Jan 2011
Location: UK

iTrader: (0)

I keep my iPod Video in there and it is always fully charged. At first I was going to suggest that you tried official cable but if you have already tried it then go back go the dealer.

Unless it doesn't (fully) support "Nano"...
Appreciate 0
      04-11-2011, 04:38 AM   #3
raccoonraccoon
New Member
0
Rep
13
Posts

 
Drives: BMW F10, 520d Automatic
Join Date: Apr 2011
Location: London

iTrader: (0)

my USB port charges my old Ipod Classic fine, but refuses to charge a newer version Ipod...it also doesnt charge my Ipad...I think its a little ridiculous...there should be enough power in that port to charge anything!
Appreciate 0
      04-11-2011, 04:54 AM   #4
cliveywolves
Private First Class
United Kingdom
6
Rep
191
Posts

 
Drives: F30 - 2013
Join Date: Feb 2008
Location: Staffordshire UK

iTrader: (0)

It always charges my iphone , im using the genuine bmw usb cable dont know if that makes any difference ?
Appreciate 0
      04-11-2011, 05:02 AM   #5
SpawneyGet
Private
United Kingdom
1
Rep
95
Posts

 
Drives: F10 535d M Sport
Join Date: Jan 2011
Location: UK

iTrader: (0)

Quote:
Originally Posted by cliveywolves View Post
It always charges my iphone , im using the genuine bmw usb cable dont know if that makes any difference ?
How much was "genuine" BMW USB cable?

I am using "genuine" Apple cable that I bought from ebay for about 3 and it charges, play and displays everything.
Appreciate 0
      04-11-2011, 05:10 AM   #6
cliveywolves
Private First Class
United Kingdom
6
Rep
191
Posts

 
Drives: F30 - 2013
Join Date: Feb 2008
Location: Staffordshire UK

iTrader: (0)

Quote:
Originally Posted by SpawneyGet View Post
How much was "genuine" BMW USB cable?

I am using "genuine" Apple cable that I bought from ebay for about 3 and it charges, play and displays everything.

From BMW there about 40 ish...

I got mine from an ebay seller for about 25 i think it was....
Appreciate 0
      04-11-2011, 06:50 AM   #7
pyramid
Private First Class
Indonesia
3
Rep
164
Posts

 
Drives: Serpent S966
Join Date: Sep 2010
Location: INA

iTrader: (0)

Garage List
Various Various  [0.00]
Quote:
Originally Posted by raccoonraccoon View Post
my USB port charges my old Ipod Classic fine, but refuses to charge a newer version Ipod...it also doesnt charge my Ipad...I think its a little ridiculous...there should be enough power in that port to charge anything!
Old ipods are using firewire input through its bottom 30pins connector for charging. All newer iPod/iPhone version (since iphone 3G release) uses 5.0v usb input pin. Thanks to Apple for un-notified changes to vendors before they release their newer iPods.

I don't have the F10 yet, but if that USB port in center console "only" meant for iPod, meaning its internal electrical wiring still aiming iPod firewire pin for charging instead of USB. Two options for you, there are some vendor making firewire to usb converter for this purposes, or asked BMW to change to newer electrical wiring/device for iPod related connection. In mercedes, it is only a matter of changing a small electrical device meant for iPod.

But I agree, it should not be happening since F10 was released way after iPhone 3G.
Appreciate 0
      04-11-2011, 07:19 AM   #8
ghueser
Lieutenant
12
Rep
513
Posts

 
Drives: 2014 M5
Join Date: May 2010
Location: St. Louis

iTrader: (0)

Quote:
Originally Posted by JPHender View Post
I discovered inadvertently that the USB port in the center console does not charge my iPod. Does anyone know it this is normal?

I've had the car for three months now and keep an iPod nano in the console. This past week, every time I tried to listen to the iPod, it would disconnect after one or two songs and hang, like has been reported in other threads. I finally took a look at the iPod this afternoon and found that the battery was completely dead! even though it has been plugged into the usb port continuously. I tried several cables and none charge the iPod. If this is by design, it is a HORRIBLE design. Why doesn't the usb port provide power out for charging???
JP.....

I have a 6th Gen Nano and keep it in the armerest console all the time, continuosly plugged into the USB port, using the Apple cable. To date, I have not had any charging issues and notice when I take it out every other week or so to re-sync with my computer, is always fully charged. Just a guess, but maybe the unit does not shut down or go to sleep when you shut the car off? Otherwise, the USB port should charge.
Appreciate 0
      04-11-2011, 07:42 AM   #9
Ict528i
New Member
0
Rep
28
Posts

 
Drives: 2011 528i alpine white
Join Date: Mar 2011
Location: ICT

iTrader: (0)

I use a brand new nano and an iPhone 4. They definitely charge thru the console USB
Appreciate 0
      04-11-2011, 08:18 AM   #10
radarguy
Private
United_States
0
Rep
88
Posts

 
Drives: 535ix sport; 2015 X5 35ix
Join Date: May 2010
Location: CT

iTrader: (0)

I don't have an i anything, but I use the center console USB for charging phones and other stuff compatible with USB. Jan 2011 build. I think I read where pre Sept 2010 builds may not have had enough power to charge things. Not sure about that.
Appreciate 0
      04-11-2011, 08:20 AM   #11
cliveywolves
Private First Class
United Kingdom
6
Rep
191
Posts

 
Drives: F30 - 2013
Join Date: Feb 2008
Location: Staffordshire UK

iTrader: (0)

Quote:
Originally Posted by radarguy View Post
I don't have an i anything, but I use the center console USB for charging phones and other stuff compatible with USB. Jan 2011 build. I think I read where pre Sept 2010 builds may not have had enough power to charge things. Not sure about that.

Yeah its always worked 100% ok for me too, my F10 is a August 2010 build
Appreciate 0
      04-13-2011, 11:08 AM   #12
raccoonraccoon
New Member
0
Rep
13
Posts

 
Drives: BMW F10, 520d Automatic
Join Date: Apr 2011
Location: London

iTrader: (0)

has anyone seen if they can charge an ipad off this port?
Appreciate 0
      04-13-2011, 11:12 AM   #13
cliveywolves
Private First Class
United Kingdom
6
Rep
191
Posts

 
Drives: F30 - 2013
Join Date: Feb 2008
Location: Staffordshire UK

iTrader: (0)

Quote:
Originally Posted by raccoonraccoon View Post
has anyone seen if they can charge an ipad off this port?
Nope not tried my ipad yet, might have a look later...
Appreciate 0
      04-13-2011, 12:07 PM   #14
Autojack
Private
Autojack's Avatar
0
Rep
76
Posts

 
Drives: 2011 550i Carbon Black M-Sport
Join Date: Oct 2010
Location: Los Angeles

iTrader: (0)

My center console inputs charge my 2 year old ipod classic and also my Blackberry bold 9650. I have not tried it with an Iphone or an ipad.

I have a Sept 2010 build 2011 F10 550i
Appreciate 0
      04-16-2011, 02:55 PM   #15
paultantk
New Member
paultantk's Avatar
0
Rep
17
Posts

 
Drives: BMW 520d
Join Date: Mar 2011
Location: Malaysia

iTrader: (0)

Garage List
2011 BMW 520d  [0.00]
I had this problem. Turns out it was a cheap cable that didn't have all the pins wired. Used an original cable and charges fine.
Appreciate 0
      04-17-2011, 12:26 AM   #16
konasunset
registered
konasunset's Avatar
United_States
2
Rep
83
Posts

 
Drives: 535i titanium silvr 1/11 build
Join Date: Feb 2011
Location: kona, big island, hawaii

iTrader: (0)

Quote:
Originally Posted by JPHender View Post
I discovered inadvertently that the USB port in the center console does not charge my iPod. Does anyone know it this is normal?

I've had the car for three months now and keep an iPod nano in the console. This past week, every time I tried to listen to the iPod, it would disconnect after one or two songs and hang, like has been reported in other threads. I finally took a look at the iPod this afternoon and found that the battery was completely dead! even though it has been plugged into the usb port continuously. I tried several cables and none charge the iPod. If this is by design, it is a HORRIBLE design. Why doesn't the usb port provide power out for charging???
What generation Nano do you have? I found that my Nano Gen 2 does not connect but my Classic does.
Appreciate 0
      04-17-2011, 07:48 AM   #17
Ict528i
New Member
0
Rep
28
Posts

 
Drives: 2011 528i alpine white
Join Date: Mar 2011
Location: ICT

iTrader: (0)

It will not charge the iPad.
Appreciate 0
      03-15-2012, 08:18 AM   #18
fat dog
Private
fat dog's Avatar
1
Rep
84
Posts

 
Drives: F11 530d M Sport
Join Date: Aug 2010
Location: North East

iTrader: (0)

I have a Feb 2012 build F11 and bought an Ipod Classic 7th generation (very latest model) to use with the USB socket in the centre armrest. Although it works fine with the BMW sound system, it doesn't seem to charge. I am using the official/genuine ipod cable that came with my ipod.

Any thought or recommendations?
Appreciate 0
      03-15-2012, 10:30 AM   #19
jedpause
Second Lieutenant
jedpause's Avatar
United Kingdom
4
Rep
200
Posts

 
Drives: F10 520d M Sport Auto
Join Date: Jan 2012
Location: London

iTrader: (0)

Red face

fat_dog... I have the same iPod 160GB, and a Jan 12 car (MY 12/2011). Charges fine.

Suggest you reboot iPod (Menu and centre button hold until apple logo), and then reconnect cable to car and see.... sometimes it does not charge at first because first connection is a handshake and sometimes causes iPod to wobble (a bit like first time connecting to a PC for e.g.)
__________________
Alpine White () F10 520d M Sport Auto - 8 speed Auto/paddles - 350M 18" Dunlop Rear/Michelin Front RFT's - Deleted Sports Suspension - Tom Tom Navigation Pro
Appreciate 0
      03-16-2012, 02:47 AM   #20
martin mustang
First Lieutenant
Ireland
7
Rep
345
Posts

 
Drives: 2011 520, X3 & 88 635csi
Join Date: Apr 2011
Location: Ireland

iTrader: (0)

I had the same problem with a nano plugged in my wife's X3, it was not stable on my 5 F10, so got her a classic with more storage.
Apple tends to change the connections often, try a different iPod if you can before working on the USB.
Appreciate 0
Post Reply

Bookmarks

Tags
center console, ipod, usb port, won't charge

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 12:02 AM.




5post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST