2010 2011 BMW 5 Series Forum F10
BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read
 

2010 2011 BMW 5 Series Forum F10 F10 Technical Topics Engine, Transmission, Exhaust, Drivetrain, ECU Software Modifications Drivetrain Malfunction Error
Post Reply
 
Thread Tools Search this Thread
      07-04-2011, 03:53 PM   #1
Snowrider
New Member
United_States
1
Rep
14
Posts

 
Drives: 2011 535i Xdrive Msport
Join Date: Jan 2011
Location: NYC

iTrader: (0)

Drivetrain Malfunction Error

This pas Saturday received a drivetrain malfunction error / Dsc xdrive error and seems as if there is loss of power to back wheels. Car shakes on turns. 2011 535i xdrive Msport. I had a Jb in the car which I removed but upon removal tab broke on one of the map sensors. Should I be worried upon bringing car to dealership? I know a few people have had this issue, I am more worried of the tab on the continental map sensor though. Thoughts would be helpful.

Thx.
Appreciate 0
      07-04-2011, 04:41 PM   #2
bobblehead
Brigadier General
bobblehead's Avatar
Canada
50
Rep
3,760
Posts

 
Drives: warp speed
Join Date: Aug 2009
Location: Toronto, On

iTrader: (0)

There are bloggers reported here had similar error message and it may be related to the (low) battery issue.

As for your JB, some dealers are very strict about these sort of tunes and may even void your warranty. Dealer can always suggest it's your aftermarket tune that caused the fault. Hope your dealer is not one of them.
Appreciate 0
      07-04-2011, 05:41 PM   #3
Snowrider
New Member
United_States
1
Rep
14
Posts

 
Drives: 2011 535i Xdrive Msport
Join Date: Jan 2011
Location: NYC

iTrader: (0)

Think it would make sense to have a new sensor installed?
Appreciate 0
      07-05-2011, 03:07 PM   #4
marcielago
Private First Class
marcielago's Avatar
United Arab Emirates
2
Rep
170
Posts

 
Drives: SG F10 550i MS, CB E39 M5
Join Date: Sep 2008
Location: Abu Dhabi

iTrader: (0)

I recommend finding the error in a code reader and if its really the sensor you're talking about, replace it and then decide whether to take it to the dealer or not.

If they found out that the ECU bay has been tampered with and its the main cause of your problem, then I'm sure that they will not fix your car on warranty.
__________________
F10 550i M-sport: Space Grey/Oyster Black
E39 M5 : Carbon Black/Caramel
E39 520i : Titanium Silver/Beige (Sold)
Appreciate 0
      07-05-2011, 03:39 PM   #5
Snowrider
New Member
United_States
1
Rep
14
Posts

 
Drives: 2011 535i Xdrive Msport
Join Date: Jan 2011
Location: NYC

iTrader: (0)

Ecu bay never tampered with, just a plug and play. Seems like the drivetrain malfunction has occurred in other recent f10 builds as well.

I do not have a code reader to check the info out.
Appreciate 0
      04-07-2012, 08:19 AM   #6
Sidbass
New Member
0
Rep
22
Posts

 
Drives: 2011 550i x-drive m-sport
Join Date: May 2011
Location: Toronto

iTrader: (0)

I had this problem in my August 2011 delivery three times in 3 months. After fuel pump change and telling me a variety of things they asked what fuel I use. I said petrocanada ultra 94 octane. They measured ethanol in
My fuel which came back at 15%. They said stop using ethanol containing fuel. Told me to switch to Shell 91. It's been 2 months since. Haven't had the problem. They said its the engines way 'to protect' itself from 'bad' fuel. I found it hard to believe that the most expensive high octane fuel is bad for my F10 but hey what do I know. So far so good.
Appreciate 0
      04-07-2012, 11:28 AM   #7
bobblehead
Brigadier General
bobblehead's Avatar
Canada
50
Rep
3,760
Posts

 
Drives: warp speed
Join Date: Aug 2009
Location: Toronto, On

iTrader: (0)

Shell super. No ethanol at all.

That's why I prefer this. besides, you pay for gas, not diluted gas.
Appreciate 0
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 02:46 AM.




5post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST