2010 2011 BMW 5 Series Forum F10
BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read

2010 2011 BMW 5 Series Forum F10 F10 Technical Topics Engine, Transmission, Exhaust, Drivetrain, ECU Software Modifications Eco-Pro mode
Post Reply
Thread Tools Search this Thread
      12-03-2016, 02:32 PM   #1
Lieutenant Colonel

Drives: 2014 535i M Sport
Join Date: Jan 2015
Location: San Diego

iTrader: (0)

Eco-Pro mode

Don't know what's up but on a long freeway trip I was getting something like +80ish miles using the Eco-Pro mode at 75ish mph. Just polished off about 400 freeway miles using Eco the whole trip and only "saved" 5 miles. Huh???? Is there something up or could it be the bottle of Techron I threw in the tank? If this seems normal I won't use the Eco on the way home in a couple of days. If it's the Techron I'll give Eco another try. On a side note I got noticeably worse MPG on my Lincoln LS with a bottle of Techron in the tank.

Did I just answer my own question??
Appreciate 0
Post Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

All times are GMT -4. The time now is 02:27 PM.

Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST