2010 2011 BMW 5 Series Forum F10
BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read
 

2010 2011 BMW 5 Series Forum F10 BMW 5-Series (F10) Forums General 5-Series Sedan and Wagon (F10 / F11) Forum Cover Art with 520d
Post Reply
 
Thread Tools Search this Thread
      07-04-2012, 09:38 AM   #1
GazRad
Registered
 
Drives: 520d SE Auto
Join Date: Jul 2012
Location: Lurgan, NI

Posts: 1
iTrader: (0)

Cover Art with 520d

I've just taken delivery of a 2012 520d SE with the standard audio/idrive gadgetry. I hoped/thought that the Cover Art on my iPod would display on the monitor, but I can't get it to. Does anybody know if this is supported?
GazRad is offline  
0
Reply With Quote
      07-04-2012, 10:14 AM   #2
sj_carr
New Member
 
Drives: F10 550i 6MT
Join Date: Jun 2012
Location: South Florida

Posts: 12
iTrader: (0)

Works on my 550i - using the iPod connector.

How are you connecting?
sj_carr is offline   United_States
0
Reply With Quote
      07-04-2012, 12:52 PM   #3
snj1013
Lieutenant
 
Drives: 2011 528i
Join Date: Jul 2011
Location: Houston, TX

Posts: 537
iTrader: (1)

If not using an iPod, you may need to imbed the jpeg into your mp3 files. Google mp3tag, it is freeware software to help with this.
snj1013 is offline  
0
Reply With Quote
      07-04-2012, 02:00 PM   #4
A900ss
Private First Class
 
A900ss's Avatar
 
Drives: 2012 520d Touring
Join Date: Feb 2012
Location: Gloucestershire, UK

Posts: 143
iTrader: (0)

Also works fine on my 2012.

I'm connecting a 5th gen IPod via USB cable to the USB connector in the armrest
A900ss is offline   United Kingdom
0
Reply With Quote
      07-05-2012, 09:07 AM   #5
darrko
First Lieutenant
 
Drives: 2012 F10 520d
Join Date: Nov 2011
Location: K

Posts: 398
iTrader: (1)

I've noticed that sometimes it may take a few seconds after the songs starts playing for the cover art to show up, and also most of the time the image is very low-res instead of the crisp image you see in the promotional images put up by BMW. I would post photos but I am traveling, will do that when I get back.

If you already have iPod integration as an option for your vehicle you should check the music file itself and confirm if the cover art is even part of the file info. If the cover art displays on your iPod then it should also display on the car screen.
__________________

darrko is offline   No_Country
0
Reply With Quote
      07-06-2012, 01:34 PM   #6
en1gma
Private
 
en1gma's Avatar
 
Drives: F10 520d M-Sport
Join Date: May 2007
Location: London, UK

Posts: 68
iTrader: (0)

I have Jan 2012 build 520d with prof media (but not the Internet option). I connect my iPhone 4 using the standard Apple white USB lead via the connector in the arm rest and it works fine. Every time there is a track change, it goes back into a 'track detail' view for some seconds before showing the cover art again.

I find that where iTunes had found the cover art for CDs I had ripped, the picture is pristinely clear. Where I have copied and pasted cover pictures into iTunes from other sources (because iTunes could not find the cover art) then these can be ropey depending on the quality of the source...

Couldn't tell before on my older iPod Touch, but you can on the retina screen on the iPhone 4!
en1gma is offline   United Kingdom
0
Reply With Quote
      07-06-2012, 03:33 PM   #7
Bimmernerd
Second Lieutenant
 
Bimmernerd's Avatar
 
Drives: 530dM xDrive F11 2012
Join Date: Nov 2011
Location: Stockholm

Posts: 242
iTrader: (0)

And my problem is that the iDrive screen every once in a while shows the wrong cover art, when you change track the cover art does not change...anyone else have this problem? I use iPhone 4 (iOS 5.1) connected through USB, F11 built in Nov 2011...quite annoying
Bimmernerd is offline   Sweden
0
Reply With Quote
      07-07-2012, 06:50 AM   #8
en1gma
Private
 
en1gma's Avatar
 
Drives: F10 520d M-Sport
Join Date: May 2007
Location: London, UK

Posts: 68
iTrader: (0)

Quote:
Originally Posted by Bimmernerd
And my problem is that the iDrive screen every once in a while shows the wrong cover art, when you change track the cover art does not change...anyone else have this problem? I use iPhone 4 (iOS 5.1) connected through USB, F11 built in Nov 2011...quite annoying
You might want to check in your iTunes library that all tracks within an album have the right cover art associated.

Typically, when using an iPhone or iPod, you never really look at the cover art after you've chosen what you want to listen to. However, in the car, the cover art is always visible...
en1gma is offline   United Kingdom
0
Reply With Quote
      07-07-2012, 09:18 AM   #9
Bimmernerd
Second Lieutenant
 
Bimmernerd's Avatar
 
Drives: 530dM xDrive F11 2012
Join Date: Nov 2011
Location: Stockholm

Posts: 242
iTrader: (0)

Quote:
Originally Posted by en1gma
Quote:
Originally Posted by Bimmernerd
And my problem is that the iDrive screen every once in a while shows the wrong cover art, when you change track the cover art does not change...anyone else have this problem? I use iPhone 4 (iOS 5.1) connected through USB, F11 built in Nov 2011...quite annoying
You might want to check in your iTunes library that all tracks within an album have the right cover art associated.

Typically, when using an iPhone or iPod, you never really look at the cover art after you've chosen what you want to listen to. However, in the car, the cover art is always visible...
Nope, there is something wrong with the car. The iPhone always shows the right cover art...
Bimmernerd is offline   Sweden
0
Reply With Quote
      07-27-2012, 02:05 AM   #10
Dandle
Private
 
Drives: F11 530d M-Sport
Join Date: Jul 2012
Location: West London

Posts: 80
iTrader: (0)

Quote:
Originally Posted by Bimmernerd View Post
Nope, there is something wrong with the car. The iPhone always shows the right cover art...
Did you get a fix for this? My iPod shows the correct cover art but iDrive never displays any.
Dandle is offline   United Kingdom
0
Reply With Quote
      07-27-2012, 01:51 PM   #11
Bimmernerd
Second Lieutenant
 
Bimmernerd's Avatar
 
Drives: 530dM xDrive F11 2012
Join Date: Nov 2011
Location: Stockholm

Posts: 242
iTrader: (0)

Quote:
Originally Posted by Dandle
Quote:
Originally Posted by Bimmernerd View Post
Nope, there is something wrong with the car. The iPhone always shows the right cover art...
Did you get a fix for this? My iPod shows the correct cover art but iDrive never displays any.
No I have not bothered to go to my dealer and get it fixed...will make a change from iPhone 4 to Samsung Galaxy S3 soon, maybe it works better.

I discovered some weeks ago that it not only displays the wrong cover art but once in a while also the wrong track name/artist...quite amazing how badly this is implemented on a 60 000 EUR car
Bimmernerd is offline   Sweden
0
Reply With Quote
      07-28-2012, 04:02 PM   #12
Dandle
Private
 
Drives: F11 530d M-Sport
Join Date: Jul 2012
Location: West London

Posts: 80
iTrader: (0)

Right I found the fix for my issues. It was the BMW y-lead which won't show cover art from the iPod, if I use the original apple iPod lead with just USB it plays the songs and shows cover art.
Dandle is offline   United Kingdom
0
Reply With Quote
      07-31-2012, 01:51 AM   #13
Bimmernerd
Second Lieutenant
 
Bimmernerd's Avatar
 
Drives: 530dM xDrive F11 2012
Join Date: Nov 2011
Location: Stockholm

Posts: 242
iTrader: (0)

Quote:
Originally Posted by Dandle View Post
Right I found the fix for my issues. It was the BMW y-lead which won't show cover art from the iPod, if I use the original apple iPod lead with just USB it plays the songs and shows cover art.
I have always used the original iPhone USB cable...obviously the cable is not the source of the problem in my case.
Bimmernerd is offline   Sweden
0
Reply With Quote
      07-31-2012, 04:49 AM   #14
islandnipper
Private First Class
 
islandnipper's Avatar
 
Drives: MY 2012 F10 520d SE
Join Date: Oct 2011
Location: Isle of Wight, UK

Posts: 118
iTrader: (0)

Quote:
Originally Posted by Dandle View Post
Right I found the fix for my issues. It was the BMW y-lead which won't show cover art from the iPod, if I use the original apple iPod lead with just USB it plays the songs and shows cover art.
Yep, that's exactly it. There was quite a lot of chat about the problem here, when the cover art feature appeared for our F10/F11 orders. The Y-lead not only is no longer required, it doesn't work (I suppose those of us that moved from E60/61s just wanted to justify our earlier 45 expense of the special lead!).

The standard iPod lead is the correct connection method and you should now be fine.
islandnipper is offline  
0
Reply With Quote
      07-31-2012, 06:27 AM   #15
Bimmernerd
Second Lieutenant
 
Bimmernerd's Avatar
 
Drives: 530dM xDrive F11 2012
Join Date: Nov 2011
Location: Stockholm

Posts: 242
iTrader: (0)

Quote:
Originally Posted by islandnipper View Post
Yep, that's exactly it. There was quite a lot of chat about the problem here, when the cover art feature appeared for our F10/F11 orders. The Y-lead not only is no longer required, it doesn't work (I suppose those of us that moved from E60/61s just wanted to justify our earlier 45 expense of the special lead!).

The standard iPod lead is the correct connection method and you should now be fine.
As you saw in my previous post the solution to my problem with incorrect cover art and/or track name/artist is NOT an iPhone USB cable...
Bimmernerd is offline   Sweden
0
Reply With Quote
      07-31-2012, 08:48 AM   #16
islandnipper
Private First Class
 
islandnipper's Avatar
 
Drives: MY 2012 F10 520d SE
Join Date: Oct 2011
Location: Isle of Wight, UK

Posts: 118
iTrader: (0)

Quote:
Originally Posted by Bimmernerd View Post
As you saw in my previous post the solution to my problem with incorrect cover art and/or track name/artist is NOT an iPhone USB cable...
Yes, sorry Bimmernerd, I was referring specifically to Dandle's post then...

I remember that when I ordered my MY2012 car (del Oct) there were a lot of iPhone/iPod connectivity requirements that had to be added to get everything to operate correctly. The dealer sorted it all out in the end without any extra input from me, so cant remember the part numbers, but the order referred to "media connectivity". I wonder whether there is some part missing in your build that a dealer may be able to help with?
islandnipper is offline  
0
Reply With Quote
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 07:46 AM.




5post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST