2010 2011 BMW 5 Series Forum F10
BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read
 

2010 2011 BMW 5 Series Forum F10 F10 Technical Topics Engine, Transmission, Exhaust, Drivetrain, ECU Software Modifications RaceChip Ultimate Install Pictures for 535i (F10), aFe Scorcher, BMS Stage1 Thoughts?
Post Reply
 
Thread Tools Search this Thread
      12-11-2014, 06:25 PM   #1
TShoot
Private
TShoot's Avatar
10
Rep
69
Posts

Drives: 535xi
Join Date: Oct 2014
Location: Maryland

iTrader: (0)

RaceChip Ultimate Install Pictures for 535i (F10), aFe Scorcher, BMS Stage1 Thoughts?

I'm thinking about buying a RaceChip Ultimate. Does anybody here have any installation pictures for a 535i (F10). Just wanted to know out of curiosity what the actual installation entailed.

I installed an aFe Scorcher and it is just a basic two connection TMAP/MAP sensor setup like the BMS Stage 1.

I really like the "feel" of the car now. No, I didn't get any dyno runs on it. I only installed it two days ago in the rain, as the sun was going down in a parking lot freezin' my arse off. Did a couple of highway full throttle runs and from some from a dead stop both in regular and sport mode. If definitely pulls a lot harder and it hits the 7000RPM mark much faster. Could not really tell much difference running it in normal drive mode and sport mode. Felt about the same - still way better than stock.

Also, has anybody tested the three tunes on the same car - RC Ultimate, aFe Scorcher and BMS Stage 1? If so, what did you think about each one?

Thanks in advance!

Last edited by TShoot; 12-11-2014 at 06:27 PM. Reason: Spelling error
Appreciate 0
      12-15-2014, 06:52 PM   #2
lsturbointeg
First Lieutenant
United_States
9
Rep
336
Posts

Drives: 2011 535i jet black
Join Date: Aug 2014
Location: Fremont, OH

iTrader: (0)

Thought about getting this? Is this basically a Turbo booster? Can u set the PSI or are they preset?
Appreciate 0
      12-15-2014, 10:27 PM   #3
ROBNYC
Captain
ROBNYC's Avatar
United_States
67
Rep
693
Posts

Drives: 14' X3 28i M-Sport AW RaceChip
Join Date: Apr 2012
Location: NYC/NJ

iTrader: (3)

Garage List
Send a message via AIM to ROBNYC
This is what RaceChip sent me but my engine is different but hope this helps and gives you an idea.
I am going to let the RaceChip X5 folks know of your thread so they can chime in.
I looked over at the aFe Scorcher and BMS Installation to see which one guides me the best.
Your previous aFe installation will help as RaceChip only plugs into 3 sensors.
Attached Images
     
__________________
PM Me for RaceChip Discount
'14 X3 28i M-Sport | Alpine White| DHP| Oyster Nevada, Premium, Cold Weather| Tech| Xenons| Prem Hi-Fi| Continental DWS| Escort RedLine| Llumar 20%| RaceChip Ultimate

X3 28i Racechip vs X3 28i Dinan vs 35i http://youtu.be/yKodPDcK3BA
Appreciate 0
      12-15-2014, 11:01 PM   #4
TShoot
Private
TShoot's Avatar
10
Rep
69
Posts

Drives: 535xi
Join Date: Oct 2014
Location: Maryland

iTrader: (0)

Quote:
Originally Posted by lsturbointeg View Post
Thought about getting this? Is this basically a Turbo booster? Can u set the PSI or are they preset?
Preset on the aFe Scorcher (12.5 PSI), preset on BMS Stage 1 (I think 12.5 PSI also or close) and adjustable on the RaceChip Ultimate.

Stock boost on 535i is about 8 PSI as a reference.
Appreciate 0
      12-15-2014, 11:08 PM   #5
TShoot
Private
TShoot's Avatar
10
Rep
69
Posts

Drives: 535xi
Join Date: Oct 2014
Location: Maryland

iTrader: (0)

ROBNYC,

Mine only showed two attachment points on the very generic photo I could get out of RC USA. Same two places the aFe Scorcher attached.
Attached Images
 
Appreciate 0
      12-15-2014, 11:11 PM   #6
ROBNYC
Captain
ROBNYC's Avatar
United_States
67
Rep
693
Posts

Drives: 14' X3 28i M-Sport AW RaceChip
Join Date: Apr 2012
Location: NYC/NJ

iTrader: (3)

Garage List
Send a message via AIM to ROBNYC
Quote:
Originally Posted by TShoot View Post
ROBNYC,

Mine only showed two attachment points on the very generic photo I could get out of RC USA. Same two places the aFe Scorcher attached.
Ask RC-USA, DTm, RPS for installation pictures before you order it.
Familiarize yourself and see what you think.
__________________
PM Me for RaceChip Discount
'14 X3 28i M-Sport | Alpine White| DHP| Oyster Nevada, Premium, Cold Weather| Tech| Xenons| Prem Hi-Fi| Continental DWS| Escort RedLine| Llumar 20%| RaceChip Ultimate

X3 28i Racechip vs X3 28i Dinan vs 35i http://youtu.be/yKodPDcK3BA
Appreciate 0
      12-15-2014, 11:16 PM   #7
TShoot
Private
TShoot's Avatar
10
Rep
69
Posts

Drives: 535xi
Join Date: Oct 2014
Location: Maryland

iTrader: (0)

Oh, and mine did not have the easy to snap off clips on the air filter box.

It has 6 #T25 torx screws to get to the MAP sensor behind it. Not a big deal, but the aFe Scorcher directions had me take off more that I really needed to.
Attached Images
 
Appreciate 0
      12-16-2014, 08:02 AM   #8
TShoot
Private
TShoot's Avatar
10
Rep
69
Posts

Drives: 535xi
Join Date: Oct 2014
Location: Maryland

iTrader: (0)

Quote:
Originally Posted by ROBNYC View Post
Ask RC-USA, DTm, RPS for installation pictures before you order it.
Familiarize yourself and see what you think.
I did but only got one picture from RC USA (above), about 5 from RPS (unrelated to install but one good picture of TMAP sensor that I already had myself) and none from DTM (he said they come with chip).

Not really worried about it since it looks like it only has two connections like the aFe.

If I have time, I'll document the installation with better pictures. All depends on the weather since I'll be doing it outside.

Really surprises me that the installation instructions are so bad but I guess they have to cover so many vehicles that you couldn't spend much time properly documenting each one with decent pictures.

ROBNYC, thanks for your pictures. Did you install yours yet? Impressions?
Appreciate 0
      12-16-2014, 08:55 AM   #9
ROBNYC
Captain
ROBNYC's Avatar
United_States
67
Rep
693
Posts

Drives: 14' X3 28i M-Sport AW RaceChip
Join Date: Apr 2012
Location: NYC/NJ

iTrader: (3)

Garage List
Send a message via AIM to ROBNYC
Quote:
Originally Posted by TShoot View Post
I did but only got one picture from RC USA (above), about 5 from RPS (unrelated to install but one good picture of TMAP sensor that I already had myself) and none from DTM (he said they come with chip).

Not really worried about it since it looks like it only has two connections like the aFe.

If I have time, I'll document the installation with better pictures. All depends on the weather since I'll be doing it outside.

Really surprises me that the installation instructions are so bad but I guess they have to cover so many vehicles that you couldn't spend much time properly documenting each one with decent pictures.

ROBNYC, thanks for your pictures. Did you install yours yet? Impressions?
Opasha helped me with everything have to thank him once again

I looked at aFe and BMS install took the idea from there, then I noticed RaceChip only plugs into 3 sensor/socket in my car. aFe plugs into 2.
So it should be straight forward for you, you should definitely see if oPasha can help you as well and write an Installation guide

Yes RC installation guide isn't all that helpful since they're mostly known in Europe and their installation seems to be used by folks who know what they're doing already.

I am going to write a Installation Guide soon with pictures and videos for RaceChip on the N20 engine. I sent Opasha pics and videos so we were finding the best way to do it and I am waiting to have time during day light to install but its been too cold lately so hopefully today or tomorrow.
__________________
PM Me for RaceChip Discount
'14 X3 28i M-Sport | Alpine White| DHP| Oyster Nevada, Premium, Cold Weather| Tech| Xenons| Prem Hi-Fi| Continental DWS| Escort RedLine| Llumar 20%| RaceChip Ultimate

X3 28i Racechip vs X3 28i Dinan vs 35i http://youtu.be/yKodPDcK3BA
Appreciate 0
      12-16-2014, 08:44 PM   #10
TShoot
Private
TShoot's Avatar
10
Rep
69
Posts

Drives: 535xi
Join Date: Oct 2014
Location: Maryland

iTrader: (0)

Just got the RaceChip install pictures for my engine. If I hadn't done it before it certainly isn't that intuitive - at least I don't think it is.
Attached Images
    
Appreciate 0
      12-16-2014, 09:14 PM   #11
TShoot
Private
TShoot's Avatar
10
Rep
69
Posts

Drives: 535xi
Join Date: Oct 2014
Location: Maryland

iTrader: (0)

If you combine the previous photos with these, it helps to see where things are really located. #2 is rear MAP sensor and #3 is TMAP sensor.
Attached Images
     
Appreciate 0
      12-16-2014, 09:39 PM   #12
ROBNYC
Captain
ROBNYC's Avatar
United_States
67
Rep
693
Posts

Drives: 14' X3 28i M-Sport AW RaceChip
Join Date: Apr 2012
Location: NYC/NJ

iTrader: (3)

Garage List
Send a message via AIM to ROBNYC
Can you take a picture of the harness connectors on your car (close-up) to see how they look ? The one on the throttle body is what I'm trying to compare to mine.

So RaceChip says only connects to 2 places ?
__________________
PM Me for RaceChip Discount
'14 X3 28i M-Sport | Alpine White| DHP| Oyster Nevada, Premium, Cold Weather| Tech| Xenons| Prem Hi-Fi| Continental DWS| Escort RedLine| Llumar 20%| RaceChip Ultimate

X3 28i Racechip vs X3 28i Dinan vs 35i http://youtu.be/yKodPDcK3BA
Appreciate 0
      12-16-2014, 11:46 PM   #13
r33
Colonel
r33's Avatar
United_States
173
Rep
2,269
Posts

Drives: F10 F15
Join Date: Oct 2009
Location: So. Cal

iTrader: (0)

Guys, I believe, the 3 connector is for the N20/N26 setup. While the N55, only uses the TMAP and MAP sensors.
All these different brands, they all uses the same sensors and similar configuration.
I have 528i where I have to plugged in all 3 sensors + 1 pneumatic wastegate solenoid when I had the BMS Stage 1. But when I moved to the BMS JB4 Stage 2, I only need the TMAP, MAP, and the Pneumatic wastegate solenoid sensors plugged.
While on my X5 35i, BMS Stage 1 and BMS JB4 Stage 2, I only need to plugged in the TMAP and MAP (No Wastegate, since it is Electronic version, but I added the EWG harness on my JB4 Stage 2).
I may be wrong, but those are my summary from seeing all of these different companies tuning installation instructions.
__________________
Appreciate 0
      12-17-2014, 09:35 PM   #14
ROBNYC
Captain
ROBNYC's Avatar
United_States
67
Rep
693
Posts

Drives: 14' X3 28i M-Sport AW RaceChip
Join Date: Apr 2012
Location: NYC/NJ

iTrader: (3)

Garage List
Send a message via AIM to ROBNYC
@r33 is right
@Tshoot

View my installation pics today
Attached Images
   
__________________
PM Me for RaceChip Discount
'14 X3 28i M-Sport | Alpine White| DHP| Oyster Nevada, Premium, Cold Weather| Tech| Xenons| Prem Hi-Fi| Continental DWS| Escort RedLine| Llumar 20%| RaceChip Ultimate

X3 28i Racechip vs X3 28i Dinan vs 35i http://youtu.be/yKodPDcK3BA
Appreciate 0
      12-18-2014, 06:33 PM   #15
TShoot
Private
TShoot's Avatar
10
Rep
69
Posts

Drives: 535xi
Join Date: Oct 2014
Location: Maryland

iTrader: (0)

Quote:
Originally Posted by r33 View Post
Guys, I believe, the 3 connector is for the N20/N26 setup. While the N55, only uses the TMAP and MAP sensors.
All these different brands, they all uses the same sensors and similar configuration.
I have 528i where I have to plugged in all 3 sensors + 1 pneumatic wastegate solenoid when I had the BMS Stage 1. But when I moved to the BMS JB4 Stage 2, I only need the TMAP, MAP, and the Pneumatic wastegate solenoid sensors plugged.
While on my X5 35i, BMS Stage 1 and BMS JB4 Stage 2, I only need to plugged in the TMAP and MAP (No Wastegate, since it is Electronic version, but I added the EWG harness on my JB4 Stage 2).
I may be wrong, but those are my summary from seeing all of these different companies tuning installation instructions.
I think you are right. I just got the RaceChip in today (too late to install). It came with just two connections that go to the same place as the aFe Scorcher and BMS Stage 1.

The strange thing, and what confused me at first, was that the aFe module harness has similar looking connectors for the TMAP and MAP sensors but had to be plugged in specifically to one or the other based on the color of wiring on the aFe connectors.

The RaceChip came with the two connector harness but no indication of which one needed to be plugged in to the TMAP and MAP sensor. When I called in, they said it didn't matter which connector I plugged into which sensor, it would "auto-detect" and work just fine.

r33, I have never had a BMS Stage 1, could you just plug the connectors into either the TMAP or MAP sensors without regard to which connector it was and it would "auto-detect" or did you have to plug a specific connector into the TMAP sensor and the other to the MAP connector by wire colors?

For the RaceChip module, it had very, very limited info out of the box with regards to installation instructions for the 535i. Mine were not color coded at all like yours ROBNYC. I just got a clear bag with a harnass in it and that was it.

When I get a chance, I'll take pictures. I have to take the car in for service on Monday so I won't get a chance to install the RaceChip until after that.

Also, still need to take off the aFe first. :-)

Going to miss that extra kick from the aFe but hopefully the RaceChip will surpass it when finally get to put it in.
Appreciate 0
      12-18-2014, 06:34 PM   #16
TShoot
Private
TShoot's Avatar
10
Rep
69
Posts

Drives: 535xi
Join Date: Oct 2014
Location: Maryland

iTrader: (0)

Quote:
Originally Posted by ROBNYC View Post
@r33 is right
@Tshoot

View my installation pics today
Did you get to run it for a bit? Any thoughts?
Appreciate 0
      12-18-2014, 06:42 PM   #17
r33
Colonel
r33's Avatar
United_States
173
Rep
2,269
Posts

Drives: F10 F15
Join Date: Oct 2009
Location: So. Cal

iTrader: (0)

@TShoot, it has to connect to the correct TMAP or MAP sensor on BMS case.
Not sure with RaceChip.
Post the picture when you got a chance, maybe I can help.
__________________
Appreciate 0
      12-18-2014, 08:31 PM   #18
TShoot
Private
TShoot's Avatar
10
Rep
69
Posts

Drives: 535xi
Join Date: Oct 2014
Location: Maryland

iTrader: (0)

Quote:
Originally Posted by r33 View Post
@TShoot, it has to connect to the correct TMAP or MAP sensor on BMS case.
Not sure with RaceChip.
Post the picture when you got a chance, maybe I can help.
Sure thing. Thanks!
Appreciate 0
      12-20-2014, 07:33 PM   #19
ROBNYC
Captain
ROBNYC's Avatar
United_States
67
Rep
693
Posts

Drives: 14' X3 28i M-Sport AW RaceChip
Join Date: Apr 2012
Location: NYC/NJ

iTrader: (3)

Garage List
Send a message via AIM to ROBNYC
Quote:
Originally Posted by TShoot View Post
Did you get to run it for a bit? Any thoughts?
Yes I did here's my thoughts.
My factory settings came in C for my engine

First day Thursday evening at stock Settings immediately felt an improvement in Sport Mode, switch to Sport+ and its even more noticeable., Comfort feels live as usual, EcoPro a bit too. After driving 30-50 miles and noticed my MPG improved.

24hrs later I decided to increase to the next level D.
Drove about 50 miles and def noticed improvement on all modes including MPG improvement.

19hrs later I decided to increase to next level E.. no errors no lights or anything so I thought to myself ok lets play with this setting for a few days 100 miles. Drove in highway and traffic for the next 30-40 miles. Feel the gains in every mode, MPG improvement is not as big as C/D setting. Gains are more live here for sure.

I haven't had a chance to test my 0-60 yet, but that is my next step now I'll plug in the dummy and test 0-60 in each mode and at my chosen setting.
__________________
PM Me for RaceChip Discount
'14 X3 28i M-Sport | Alpine White| DHP| Oyster Nevada, Premium, Cold Weather| Tech| Xenons| Prem Hi-Fi| Continental DWS| Escort RedLine| Llumar 20%| RaceChip Ultimate

X3 28i Racechip vs X3 28i Dinan vs 35i http://youtu.be/yKodPDcK3BA
Appreciate 0
      12-21-2014, 05:06 PM   #20
TShoot
Private
TShoot's Avatar
10
Rep
69
Posts

Drives: 535xi
Join Date: Oct 2014
Location: Maryland

iTrader: (0)

Quote:
Originally Posted by ROBNYC View Post
Yes I did here's my thoughts.
My factory settings came in C for my engine

First day Thursday evening at stock Settings immediately felt an improvement in Sport Mode, switch to Sport+ and its even more noticeable., Comfort feels live as usual, EcoPro a bit too. After driving 30-50 miles and noticed my MPG improved.

24hrs later I decided to increase to the next level D.
Drove about 50 miles and def noticed improvement on all modes including MPG improvement.

19hrs later I decided to increase to next level E.. no errors no lights or anything so I thought to myself ok lets play with this setting for a few days 100 miles. Drove in highway and traffic for the next 30-40 miles. Feel the gains in every mode, MPG improvement is not as big as C/D setting. Gains are more live here for sure.

I haven't had a chance to test my 0-60 yet, but that is my next step now I'll plug in the dummy and test 0-60 in each mode and at my chosen setting.
Didn't waste any time moving up the settings did you?

Good to hear that you are liking it so far. I can't wait to install mine. I have a service appointment tomorrow. Removed the aFe Scorcher setup yesterday.

If it wasn't for the fear of breaking the clips on the sensors, it would literally be less than a 10 minute install/de-install.

Hope to install the RC tomorrow evening if it isn't raining too hard. My stock setting is B (for S2) and 1 (for S1).

Thanks for the feedback!
Appreciate 0
      12-21-2014, 08:40 PM   #21
ROBNYC
Captain
ROBNYC's Avatar
United_States
67
Rep
693
Posts

Drives: 14' X3 28i M-Sport AW RaceChip
Join Date: Apr 2012
Location: NYC/NJ

iTrader: (3)

Garage List
Send a message via AIM to ROBNYC
Quote:
Originally Posted by TShoot View Post
Didn't waste any time moving up the settings did you?

Good to hear that you are liking it so far. I can't wait to install mine. I have a service appointment tomorrow. Removed the aFe Scorcher setup yesterday.

If it wasn't for the fear of breaking the clips on the sensors, it would literally be less than a 10 minute install/de-install.

Hope to install the RC tomorrow evening if it isn't raining too hard. My stock setting is B (for S2) and 1 (for S1).

Thanks for the feedback!
haha I sure didn't and I been driving more now with the Chip on for that purpose to find the sweet spot before it starts snowing and colder. So far I can say I'm impressed with every setting there's definitely more power but haven't had the chance to test 0-60 yet and when I did have the space (too many cops) in my sight.

Definitely keep the stock settings for at least 50 miles so you can get a feeling also in all different modes start off from EcoPro, then Comfort, then Sport.

Good Luck with your install @r33 and @opasha helped me a lot
__________________
PM Me for RaceChip Discount
'14 X3 28i M-Sport | Alpine White| DHP| Oyster Nevada, Premium, Cold Weather| Tech| Xenons| Prem Hi-Fi| Continental DWS| Escort RedLine| Llumar 20%| RaceChip Ultimate

X3 28i Racechip vs X3 28i Dinan vs 35i http://youtu.be/yKodPDcK3BA
Appreciate 0
      12-21-2014, 08:47 PM   #22
r33
Colonel
r33's Avatar
United_States
173
Rep
2,269
Posts

Drives: F10 F15
Join Date: Oct 2009
Location: So. Cal

iTrader: (0)

@ROBNYC,
__________________
Appreciate 0
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 06:26 AM.




5post
5post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST