2010 2011 BMW 5 Series Forum F10
BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read
 

2010 2011 BMW 5 Series Forum F10 F10 Technical Topics Engine, Transmission, Exhaust, Drivetrain, ECU Software Modifications Jb4 Stage 2 4 extra Wires HELP!!
Post Reply
 
Thread Tools Search this Thread
      12-03-2012, 11:09 PM   #1
obiltagi3
V.I.P.
 
obiltagi3's Avatar
 
Drives: F10 (2011 535i)
Join Date: Dec 2012
Location: Tustin, Orange County

Posts: 50
iTrader: (0)

Jb4 Stage 2 4 extra Wires HELP!!

Hello, i just bought Stage 2 JB4. I followed instructions online for installation. But i am stuck at the last part. What do i do with the four extra wires? Ground, red, brown, green. Where do they plug into? Pictures Please


I tried to follow the instructions but it fails to show pictures for the F10 so i am unable to tell where each one goes
obiltagi3 is offline   United_States
0
Reply With Quote
      12-03-2012, 11:29 PM   #2
Alan l.
Brigadier General
 
Alan l.'s Avatar
 
Drives: LCI M-Sport 550i
Join Date: Jun 2009
Location: East Coast

Posts: 4,375
iTrader: (8)

http://www.n54tech.com/forums/showpo...16&postcount=3
__________________

2014 LCI 550i M Sport | 3D Design Front Spoiler | BMW Performance Black Grills | BMW Performance Trunk Lip | BMW Performance Diffuser | Painted Reflectors | Wincos 30% Tint | Supersprint Exhaust | ACSSprings | MORR VS8.2 Rims 20x10R and 20x9F | Michelin PSS Tires |||More Photos of my car here|||
Alan l. is offline  
0
Reply With Quote
      12-03-2012, 11:42 PM   #3
obiltagi3
V.I.P.
 
obiltagi3's Avatar
 
Drives: F10 (2011 535i)
Join Date: Dec 2012
Location: Tustin, Orange County

Posts: 50
iTrader: (0)

Thank you.. i bought stage 2 for nothing i guess. If i dont have connectors C & D (The Red Squares) it wont work correct?
obiltagi3 is offline   United_States
0
Reply With Quote
      12-04-2012, 01:33 AM   #4
obiltagi3
V.I.P.
 
obiltagi3's Avatar
 
Drives: F10 (2011 535i)
Join Date: Dec 2012
Location: Tustin, Orange County

Posts: 50
iTrader: (0)

Just installed the Jb4 Stage two. Unfortunetly i did not have the right connections for the 4 wires im guessing. Although according to that link you can just set the 4 wires aside. Which i did. Now reconnecting the battery and starting the car i receive a DRIVETRAIN MALFUNCTION CODE...

Any help?
obiltagi3 is offline   United_States
0
Reply With Quote
      12-04-2012, 08:14 AM   #5
Alan l.
Brigadier General
 
Alan l.'s Avatar
 
Drives: LCI M-Sport 550i
Join Date: Jun 2009
Location: East Coast

Posts: 4,375
iTrader: (8)

The control box is supposedly different between S1 and S2 so you can't just run it without those wires installed according to Terry. If your car doesn't look like the pics posted then you need to run only S1.

Alan
__________________

2014 LCI 550i M Sport | 3D Design Front Spoiler | BMW Performance Black Grills | BMW Performance Trunk Lip | BMW Performance Diffuser | Painted Reflectors | Wincos 30% Tint | Supersprint Exhaust | ACSSprings | MORR VS8.2 Rims 20x10R and 20x9F | Michelin PSS Tires |||More Photos of my car here|||
Alan l. is offline  
0
Reply With Quote
      12-04-2012, 08:18 AM   #6
Rbembas_M3
First Lieutenant
 
Rbembas_M3's Avatar
 
Drives: BMW 2011 M3
Join Date: Jan 2012
Location: BUFORD GA

Posts: 358
iTrader: (0)

Garage List
2011 BMW M3  [0.00]
Quote:
Originally Posted by obiltagi3 View Post
Just installed the Jb4 Stage two. Unfortunetly i did not have the right connections for the 4 wires im guessing. Although according to that link you can just set the 4 wires aside. Which i did. Now reconnecting the battery and starting the car i receive a DRIVETRAIN MALFUNCTION CODE...

Any help?
yes i had the same thing happen to me. I don't have the CANBUS hook-up like the pictures shows. I also got the drivetrain malfunction and engine light. I contacted Terry and he told me i can only run stage 1. They sent me stage 1 but haven't installed it yet. My car is in the shop for scheduled brake service.
Rbembas_M3 is offline   United_States
0
Reply With Quote
      12-06-2012, 05:39 AM   #7
Rbembas_M3
First Lieutenant
 
Rbembas_M3's Avatar
 
Drives: BMW 2011 M3
Join Date: Jan 2012
Location: BUFORD GA

Posts: 358
iTrader: (0)

Garage List
2011 BMW M3  [0.00]
My 2011 535i doesn't have the CANBUS location like it shown in the instruction. Does anyone know where to find the CANBUS wire harness?
Rbembas_M3 is offline   United_States
0
Reply With Quote
      12-06-2012, 09:50 AM   #8
RambleJ
Colonel
 
RambleJ's Avatar
 
Drives: F10 535i M-sport
Join Date: Oct 2008
Location: Back in teh so cal

Posts: 2,012
iTrader: (2)

Quote:
Originally Posted by rbembas535i View Post
My 2011 535i doesn't have the CANBUS location like it shown in the instruction. Does anyone know where to find the CANBUS wire harness?
If you have a 2011 I think you are stuck with Stage 1 only.
RambleJ is offline   No_Country
0
Reply With Quote
      12-06-2012, 02:16 PM   #9
Sharbotcom
First Lieutenant
 
Sharbotcom's Avatar
 
Drives: 2011 535xi M Sport
Join Date: Oct 2010
Location: Sharbot Lake, Ontario

Posts: 367
iTrader: (0)

Quote:
Originally Posted by RambleJ View Post
If you have a 2011 I think you are stuck with Stage 1 only.
My 2011 does have the CANBUS wiring so there has to be something else besides the MY that dictates its inclusion on the vehicle.
__________________
2011 535i xDrive, Dark Graphite Metallic, Veneto Beige Dakota Leather, Technology Package, M Sport Package, Executive Package delivered Christmas Eve '10, Mods - quad tips, 20% tint, JB4.
Sharbotcom is offline   Canada
0
Reply With Quote
      12-07-2012, 01:02 PM   #10
obiltagi3
V.I.P.
 
obiltagi3's Avatar
 
Drives: F10 (2011 535i)
Join Date: Dec 2012
Location: Tustin, Orange County

Posts: 50
iTrader: (0)

Nope, i got my Stage 2 installed a few days ago. Finally got it too work. Improvements are very noticeable, even in casual driving without the Sport Mode
obiltagi3 is offline   United_States
0
Reply With Quote
      12-07-2012, 02:10 PM   #11
Rbembas_M3
First Lieutenant
 
Rbembas_M3's Avatar
 
Drives: BMW 2011 M3
Join Date: Jan 2012
Location: BUFORD GA

Posts: 358
iTrader: (0)

Garage List
2011 BMW M3  [0.00]
Quote:
Originally Posted by obiltagi3 View Post
Nope, i got my Stage 2 installed a few days ago. Finally got it too work. Improvements are very noticeable, even in casual driving without the Sport Mode
how did you get your to work? weren't you get drive train malfuntion and couldn't wire up the four wires to the CANBUS?

Last edited by Rbembas_M3; 12-07-2012 at 02:26 PM.
Rbembas_M3 is offline   United_States
0
Reply With Quote
      12-07-2012, 03:11 PM   #12
///M ARMY
Major
 
Drives: F80
Join Date: Jul 2012
Location: SoCal

Posts: 1,012
iTrader: (2)

I just use the sports transmission and confront drive and it's a huge difference
__________________
2015 BMW /// M3 BSM
On order: GTHaus Meisterschaft Exhaust
///M ARMY is offline  
0
Reply With Quote
      12-08-2012, 07:21 PM   #13
obiltagi3
V.I.P.
 
obiltagi3's Avatar
 
Drives: F10 (2011 535i)
Join Date: Dec 2012
Location: Tustin, Orange County

Posts: 50
iTrader: (0)

Quote:
Originally Posted by rbembas535i View Post
how did you get your to work? weren't you get drive train malfuntion and couldn't wire up the four wires to the CANBUS?
The malfunction i figured out was a miscommunication between some wires. I was also able to figure out i DO have the right corrections, i was told i DID NOT. But fortunetly i did and was able to get in installed correctly.

First day i did not notice much
2-4 days later improvements are very noticeable
obiltagi3 is offline   United_States
0
Reply With Quote
      12-09-2012, 11:34 PM   #14
VWtoBMW
Captain
 
VWtoBMW's Avatar
 
Drives: 2013 740Li
Join Date: Aug 2009
Location: Toronto

Posts: 794
iTrader: (5)

Garage List
2013 535i xDrive  [5.00]
2009 BMW 328i  [0.00]
I finally installed mine on Friday. Drive it locally and noticed a light difference. I did a trip today which was about 300km and really noted a big difference. So far I am very pleased !
__________________
2013 F10 535i xDrive Space Grey, Oyster Napa Leather, DHP, HUD, Rear Entertainment, Luxury and Executive Package
VWtoBMW is online now   Canada
0
Reply With Quote
      12-14-2012, 02:03 PM   #15
obiltagi3
V.I.P.
 
obiltagi3's Avatar
 
Drives: F10 (2011 535i)
Join Date: Dec 2012
Location: Tustin, Orange County

Posts: 50
iTrader: (0)

Thumbs up

Quote:
Originally Posted by VWtoBMW View Post
I finally installed mine on Friday. Drive it locally and noticed a light difference. I did a trip today which was about 300km and really noted a big difference. So far I am very pleased !
obiltagi3 is offline   United_States
0
Reply With Quote
      01-12-2013, 11:19 PM   #16
mikey0120
First Lieutenant
 
Drives: F10 535Xi M-Sport
Join Date: Jul 2006
Location: Rockland County, NY

Posts: 338
iTrader: (9)

Quote:
Originally Posted by obiltagi3 View Post
The malfunction i figured out was a miscommunication between some wires. I was also able to figure out i DO have the right corrections, i was told i DID NOT. But fortunetly i did and was able to get in installed correctly.

First day i did not notice much
2-4 days later improvements are very noticeable
How did you get it to work? My harness does not have the same color codes as in the N54 tech install manual. What did you hook up brown and green to?

I have a 2013 F10 535Xi

Thanks.
__________________
Current: 2013 F10 535Xi M-Sport
Retired: 2010 E90 335i M-Sport
Retired: 2007 E90 335i
Retired: 2001 E46 330i
mikey0120 is offline   Philippines
0
Reply With Quote
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 04:56 PM.




5post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST