2010 2011 BMW 5 Series Forum F10
BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read
 

2010 2011 BMW 5 Series Forum F10 F10 Technical Topics Engine, Transmission, Exhaust, Drivetrain, ECU Software Modifications JB Stage 1 or 2 w/o Exhaust Mod
Post Reply
 
Thread Tools Search this Thread
      01-18-2013, 07:52 PM   #1
j535i
Private
 
Drives: 2012 BMW 535i xDrive
Join Date: Jan 2013
Location: Chicago

Posts: 71
iTrader: (0)

JB Stage 1 or 2 w/o Exhaust Mod

Anyone added the JB stage 1 or 2 and not immediately upgraded the exhaust? Better to wait and both mods at the same time? Or does the JB stand on its own?

Champaign problems I know...but I just paid for H&R Sport Springs, staggered 20x9-20x10.5 graphite Vossen CV3, and Continental Extreme Grip DWs (go on my 2012 535i xDrive next week) and I'd like to add JB while they have it in the shop. Buying an engagement ring this month too so trying to not get too crazy and do exhaust in late summer.

Thoughts? Thanks...
j535i is offline  
0
Reply With Quote
      01-19-2013, 09:36 AM   #2
Juiced46
Major
 
Drives: 03 Turbo Cobra, 2011 335xi
Join Date: Jun 2010
Location: Wallingford CT

Posts: 1,027
iTrader: (3)

I have been running the Stage 2 for a few days no with no plans of a downpipe change. I have a custom catback that is all but stock DP. Working great so far.
Juiced46 is offline  
0
Reply With Quote
      01-19-2013, 10:43 AM   #3
j535i
Private
 
Drives: 2012 BMW 535i xDrive
Join Date: Jan 2013
Location: Chicago

Posts: 71
iTrader: (0)

Quote:
Originally Posted by Juiced46
I have been running the Stage 2 for a few days no with no plans of a downpipe change. I have a custom catback that is all but stock DP. Working great so far.
Thanks...
j535i is offline  
0
Reply With Quote
      01-28-2013, 01:57 PM   #4
Rbembas_M3
First Lieutenant
 
Rbembas_M3's Avatar
 
Drives: BMW 2011 M3
Join Date: Jan 2012
Location: BUFORD GA

Posts: 389
iTrader: (0)

Garage List
2011 BMW M3  [0.00]
my 535i can't run stage 2 but i am running the N55 Terry told me that there isn't jb4 stage 1 they just sent me a new box maked N55. I am running it now and running 3.0 over boost, seem to running better at that setting in my 6MT. Once in awhile I do get a drive train malfuntion not sure why or if it the tune. I turn off my car and restart everything is fine. When i ran my boost at 4.5 it seem to casue more lag when i shift from first to second not feeling that now at 3.0
Rbembas_M3 is offline   United_States
0
Reply With Quote
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 02:41 AM.




5post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST