2010 2011 BMW 5 Series Forum F10
BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read
 

2010 2011 BMW 5 Series Forum F10 F10 Technical Topics Engine, Transmission, Exhaust, Drivetrain, ECU Software Modifications Haunting O2 Sensor Code
Post Reply
 
Thread Tools Search this Thread
      02-16-2024, 06:56 PM   #1
obiltagi3
V.I.P.
obiltagi3's Avatar
United_States
38
Rep
248
Posts

Drives: F10 535i 2011, F10 550i 2015
Join Date: Dec 2012
Location: Orange County

iTrader: (1)

Garage List
2015 BMW 550i  [9.00]
Haunting O2 Sensor Code

Hello everyone,

I've been experiencing rather unusual downstream O2 Sensor codes that won't go away. After countless hours of diagnosing and spending quite a bit of money i feel defeated and have finally decided to ask for some support from the community!
Just two quick notes: new O2 sensors, same codes, local shop verified O2 sensors were fine. Im aware of the Service Bulletin addressing some code fixes, current I-Level is below and newer than bulletin. I'm on BM3 currently, however, codes persist on stock flash. Any help would be much appreciated. Below is a list of parts changed and the codes im experiencing. Car drives excellent and just passed smog (I was able to catch it while the CEL was off). All monitors complete.


Replaced the downstream O2 sensors (upstream are new too)
Replaced both intake ducts
Replaced both MAF sensors
I Level is : F010-19-11-520
((2019) newer than than the bulletin)

Codes:
12AB04: Lambdasonde2 Bank1, electrical: Line break
12AC04: Lambdasonde2 Bank2, electrical: Line break
12B701: Heating Lambasonde2 bank1, function: internal resistance too high
12B801: Heating Lambasonde2 bank2, function: internal resistance too high

2015 N63TU 550i
BM3 STG1, XHP STG1, N63INTAKE OIL COOLER VALVE

I appreciate your help. Thanks
__________________
F10 550i Imperial Blue/Ivory
BM3 Stage 1 - xHP Stage 1
F10 535i Alpine White/Oyster
BMC - Vorsteiner Exhaust - ER Chargepipe - AR Catless DP - MHD Stage 2 - FMIC

Last edited by obiltagi3; 02-16-2024 at 07:04 PM..
Appreciate 0
      02-16-2024, 08:29 PM   #2
ChiltiCoatl89
Lieutenant
ChiltiCoatl89's Avatar
United_States
1759
Rep
429
Posts

Drives: 2016 F10 BMW 535i M Sport
Join Date: Jun 2023
Location: Nevada

iTrader: (0)

Garage List
Check those O2 Sensor connections very thoroughly. Something possibly with your Catted DP, however My educated guess its the connections itself.
Appreciate 0
      02-17-2024, 03:56 PM   #3
obiltagi3
V.I.P.
obiltagi3's Avatar
United_States
38
Rep
248
Posts

Drives: F10 535i 2011, F10 550i 2015
Join Date: Dec 2012
Location: Orange County

iTrader: (1)

Garage List
2015 BMW 550i  [9.00]
Quote:
Originally Posted by ChiltiCoatl89 View Post
Check those O2 Sensor connections very thoroughly. Something possibly with your Catted DP, however My educated guess its the connections itself.
Oem downpipes were installed about 2 months ago. Codes continue (ignore my signature) ) A local shop said they were able to get readings from the sensors and that they were fine... Pins are in good condition and clean.
Tip: The O2 sensors im using are the OE Bosch 15167, not original BMW. I don't see that being an issue, just wanted to share. Thanks for the input!
__________________
F10 550i Imperial Blue/Ivory
BM3 Stage 1 - xHP Stage 1
F10 535i Alpine White/Oyster
BMC - Vorsteiner Exhaust - ER Chargepipe - AR Catless DP - MHD Stage 2 - FMIC
Appreciate 1
      02-17-2024, 05:56 PM   #4
ChiltiCoatl89
Lieutenant
ChiltiCoatl89's Avatar
United_States
1759
Rep
429
Posts

Drives: 2016 F10 BMW 535i M Sport
Join Date: Jun 2023
Location: Nevada

iTrader: (0)

Garage List
Only thing else I Could think of of they are installed in the wrong banks, I am not exactly familiar and stand corrected if they're the same PNs (Or not) as I am still learning BMWs, however Back to OEM Dp you shouldn't be throwing codes like that. Good post!
Appreciate 1
      02-18-2024, 02:11 AM   #5
obiltagi3
V.I.P.
obiltagi3's Avatar
United_States
38
Rep
248
Posts

Drives: F10 535i 2011, F10 550i 2015
Join Date: Dec 2012
Location: Orange County

iTrader: (1)

Garage List
2015 BMW 550i  [9.00]
Quote:
Originally Posted by ChiltiCoatl89 View Post
Only thing else I Could think of of they are installed in the wrong banks, I am not exactly familiar and stand corrected if they're the same PNs (Or not) as I am still learning BMWs, however Back to OEM Dp you shouldn't be throwing codes like that. Good post!
Bank 1 & 2 use the Bosch 15167 for the downstream (monitor) O2 sensor.
Thanks for reaching out and I appreciate the feedback!

Anyone else have some thoughts to share? Thanks!
__________________
F10 550i Imperial Blue/Ivory
BM3 Stage 1 - xHP Stage 1
F10 535i Alpine White/Oyster
BMC - Vorsteiner Exhaust - ER Chargepipe - AR Catless DP - MHD Stage 2 - FMIC
Appreciate 1
      02-29-2024, 01:28 AM   #6
obiltagi3
V.I.P.
obiltagi3's Avatar
United_States
38
Rep
248
Posts

Drives: F10 535i 2011, F10 550i 2015
Join Date: Dec 2012
Location: Orange County

iTrader: (1)

Garage List
2015 BMW 550i  [9.00]
Bump! Willing to give a small token of appreciation to anyone who provides me a solution that fixes this!
__________________
F10 550i Imperial Blue/Ivory
BM3 Stage 1 - xHP Stage 1
F10 535i Alpine White/Oyster
BMC - Vorsteiner Exhaust - ER Chargepipe - AR Catless DP - MHD Stage 2 - FMIC
Appreciate 1
      02-29-2024, 05:27 AM   #7
ChiltiCoatl89
Lieutenant
ChiltiCoatl89's Avatar
United_States
1759
Rep
429
Posts

Drives: 2016 F10 BMW 535i M Sport
Join Date: Jun 2023
Location: Nevada

iTrader: (0)

Garage List
Not gonna ever give up on helping a fellow 5er owner!
Appreciate 1
      02-29-2024, 08:21 PM   #8
ChiltiCoatl89
Lieutenant
ChiltiCoatl89's Avatar
United_States
1759
Rep
429
Posts

Drives: 2016 F10 BMW 535i M Sport
Join Date: Jun 2023
Location: Nevada

iTrader: (0)

Garage List
Have you tried swapping the O2 sensors for new ones to make sure they are not the issue? Or one at a time? Always good to try that. For peace of mind?
Appreciate 1
      03-01-2024, 07:03 PM   #9
obiltagi3
V.I.P.
obiltagi3's Avatar
United_States
38
Rep
248
Posts

Drives: F10 535i 2011, F10 550i 2015
Join Date: Dec 2012
Location: Orange County

iTrader: (1)

Garage List
2015 BMW 550i  [9.00]
Yes I have just changed them again.
The codes continue, however, I think I have finally found the solution. Will keep updated.
__________________
F10 550i Imperial Blue/Ivory
BM3 Stage 1 - xHP Stage 1
F10 535i Alpine White/Oyster
BMC - Vorsteiner Exhaust - ER Chargepipe - AR Catless DP - MHD Stage 2 - FMIC
Appreciate 1
      03-01-2024, 07:29 PM   #10
ChiltiCoatl89
Lieutenant
ChiltiCoatl89's Avatar
United_States
1759
Rep
429
Posts

Drives: 2016 F10 BMW 535i M Sport
Join Date: Jun 2023
Location: Nevada

iTrader: (0)

Garage List
Quote:
Originally Posted by obiltagi3 View Post
Yes I have just changed them again.
The codes continue, however, I think I have finally found the solution. Will keep updated.
Stay in touch!!! This will be another for the great Archives of the F10 Series forum.
Appreciate 0
      03-02-2024, 02:48 PM   #11
obiltagi3
V.I.P.
obiltagi3's Avatar
United_States
38
Rep
248
Posts

Drives: F10 535i 2011, F10 550i 2015
Join Date: Dec 2012
Location: Orange County

iTrader: (1)

Garage List
2015 BMW 550i  [9.00]
So, I decided to diagnose many of the AFR components. (You can see above the parts I changed)
Realized itís been 35K miles on spark plugs, tuned and no misfires. Anywho, decided it was time to change plugs and coils. (I prefer to change these before a CEL, as I know the interval is coming up soon). Spark plugs looked pretty fouled. Iíve changed plugs on previous F10 over 10 years so I know how they typically look. For some reason, these plugs looked like they had some kind of buildup. Iíll post a pic for anyone who wants to chime in on what that buildup might be?

Anywho, I have not received any O2 downstream codes since the change of plugs + coils. All monitors are up (nothing changed here). No CEL. 120 miles in, will check back in a couple more hundred miles but all is looking good now. Looks like I needed spark plugs for a whole year despite car running fine and no misfires

Iíve never seen spark plugs cause O2 downstream sensors issues, can anyone explain this?

I hope this helps someone in the future! Thanks
__________________
F10 550i Imperial Blue/Ivory
BM3 Stage 1 - xHP Stage 1
F10 535i Alpine White/Oyster
BMC - Vorsteiner Exhaust - ER Chargepipe - AR Catless DP - MHD Stage 2 - FMIC
Appreciate 0
      03-02-2024, 02:52 PM   #12
obiltagi3
V.I.P.
obiltagi3's Avatar
United_States
38
Rep
248
Posts

Drives: F10 535i 2011, F10 550i 2015
Join Date: Dec 2012
Location: Orange County

iTrader: (1)

Garage List
2015 BMW 550i  [9.00]
Hereís a pic of the plugs; as you can see, many of them just look burnt or like a typical used spark plug.
However, 4 plugs, that were in cylinders 3/4 and 7/8 had some kind of rusty looking buildup.
Attached Images
 
__________________
F10 550i Imperial Blue/Ivory
BM3 Stage 1 - xHP Stage 1
F10 535i Alpine White/Oyster
BMC - Vorsteiner Exhaust - ER Chargepipe - AR Catless DP - MHD Stage 2 - FMIC
Appreciate 1
      03-02-2024, 07:28 PM   #13
ChiltiCoatl89
Lieutenant
ChiltiCoatl89's Avatar
United_States
1759
Rep
429
Posts

Drives: 2016 F10 BMW 535i M Sport
Join Date: Jun 2023
Location: Nevada

iTrader: (0)

Garage List
I am looking into what may cause the discoloration, other than normal wear, Rich/lean differences in buildup.
Appreciate 0
      03-02-2024, 07:34 PM   #14
ChiltiCoatl89
Lieutenant
ChiltiCoatl89's Avatar
United_States
1759
Rep
429
Posts

Drives: 2016 F10 BMW 535i M Sport
Join Date: Jun 2023
Location: Nevada

iTrader: (0)

Garage List
Running lean on your spark plugs, Grayish color which means plenty of air or more air to fuel, of course, and you are in OC in California? or?
Appreciate 0
      03-02-2024, 07:52 PM   #15
obiltagi3
V.I.P.
obiltagi3's Avatar
United_States
38
Rep
248
Posts

Drives: F10 535i 2011, F10 550i 2015
Join Date: Dec 2012
Location: Orange County

iTrader: (1)

Garage List
2015 BMW 550i  [9.00]
Quote:
Originally Posted by ChiltiCoatl89 View Post
Running lean on your spark plugs, Grayish color which means plenty of air or more air to fuel, of course, and you are in OC in California? or?
Interesting, I was running the front mount intake for a while. It looks and sounds good, but went back stock when I saw how much dust was coming through the PG air filter into piping
__________________
F10 550i Imperial Blue/Ivory
BM3 Stage 1 - xHP Stage 1
F10 535i Alpine White/Oyster
BMC - Vorsteiner Exhaust - ER Chargepipe - AR Catless DP - MHD Stage 2 - FMIC
Appreciate 1
      03-03-2024, 09:07 PM   #16
ChiltiCoatl89
Lieutenant
ChiltiCoatl89's Avatar
United_States
1759
Rep
429
Posts

Drives: 2016 F10 BMW 535i M Sport
Join Date: Jun 2023
Location: Nevada

iTrader: (0)

Garage List
To me the corrosion or rust looking material, my educated guess, could be from trapped moisture before the seal of the electrode of the spark plug, from condensation. Doesn't look harmful as the seal did its job. Evidence of the car being in humid conditions. Has your car ever sat for long period of time without starting? Or is it parked outside?
Appreciate 0
      03-04-2024, 02:20 PM   #17
obiltagi3
V.I.P.
obiltagi3's Avatar
United_States
38
Rep
248
Posts

Drives: F10 535i 2011, F10 550i 2015
Join Date: Dec 2012
Location: Orange County

iTrader: (1)

Garage List
2015 BMW 550i  [9.00]
200 miles in no CEL


Car is always parked outside, itís my daily driver ! The vehicle is home to California

Appreciate your help !
__________________
F10 550i Imperial Blue/Ivory
BM3 Stage 1 - xHP Stage 1
F10 535i Alpine White/Oyster
BMC - Vorsteiner Exhaust - ER Chargepipe - AR Catless DP - MHD Stage 2 - FMIC
Appreciate 1
      03-06-2024, 08:33 PM   #18
ChiltiCoatl89
Lieutenant
ChiltiCoatl89's Avatar
United_States
1759
Rep
429
Posts

Drives: 2016 F10 BMW 535i M Sport
Join Date: Jun 2023
Location: Nevada

iTrader: (0)

Garage List
Quote:
Originally Posted by obiltagi3 View Post
200 miles in no CEL


Car is always parked outside, itís my daily driver ! The vehicle is home to California

Appreciate your help !
Always!!! Happy Driving!! I go to So Cal every now and then, perhaps we all should do a Bimmers and Coffee meet somewhere lol
Appreciate 1
      03-07-2024, 08:44 PM   #19
obiltagi3
V.I.P.
obiltagi3's Avatar
United_States
38
Rep
248
Posts

Drives: F10 535i 2011, F10 550i 2015
Join Date: Dec 2012
Location: Orange County

iTrader: (1)

Garage List
2015 BMW 550i  [9.00]
Quote:
Originally Posted by ChiltiCoatl89 View Post
Always!!! Happy Driving!! I go to So Cal every now and then, perhaps we all should do a Bimmers and Coffee meet somewhere lol
Sure! Just pm me if youíre in town
__________________
F10 550i Imperial Blue/Ivory
BM3 Stage 1 - xHP Stage 1
F10 535i Alpine White/Oyster
BMC - Vorsteiner Exhaust - ER Chargepipe - AR Catless DP - MHD Stage 2 - FMIC
Appreciate 1
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 05:25 AM.




5post
Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2024, vBulletin Solutions Inc.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST