2010 2011 BMW 5 Series Forum F10
BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read
 

2010 2011 BMW 5 Series Forum F10 F10 Technical Topics Navigation, iDrive, Audio, Video, Bluetooth, Phone, Coding BMW F10 Coding DIY (and other Fxx models)
Post Reply
 
Thread Tools Search this Thread
      09-11-2018, 01:06 PM   #331
ZaphodB
Registered
0
Rep
2
Posts

Drives: 2016 BMW 528 (F10)
Join Date: Sep 2018
Location: CA

iTrader: (0)

Coding Questions

I have a 2016 528 and have been successful and coding some options, but not others.
Accoustical_Lock_confirm doesn't seem to do anything. Is there a way to disable sound when locking with the remote, but leave the sound when unlocking?
My car has the ability to dictate text messages, but only when parked. Dictation is actually allowed in CA while driving...is there way to remove this restriction using coding?
Thank you

Last edited by ZaphodB; 09-11-2018 at 01:11 PM.
Appreciate 0
      09-16-2018, 08:55 AM   #332
Bruno112
Private
Croatia
11
Rep
91
Posts

Drives: 2014 F10 530d MSport
Join Date: Aug 2013
Location: Croatia

iTrader: (0)

Did you try with this in HU_NBT?

Disable Office Function Speed Lock-Out
3000 OFFICE_MESSAGES_SPEEDLOCK_CONDITION set to: nicht_aktiv

Enable Full Text Lines in Office While Driving
3003  PIM_DRIVING_TEXT_LENGTH set to: whole text_07
Appreciate 0
      09-17-2018, 03:33 PM   #333
pcp1234
Private
5
Rep
62
Posts

Drives: F10
Join Date: Jul 2018
Location: Leeds

iTrader: (0)

hi guys

is it normal that engine management light comes on after odd flash ? reading ista d, it obviously sees faults from flashing stage but actual car is ok

also i was under impression that EPS hasn't been updated because of below message but now its no longer on list of items to update. has it been flashed ok in the end ?

https://ibb.co/h3WRme
Appreciate 0
      09-19-2018, 10:23 AM   #334
ZaphodB
Registered
0
Rep
2
Posts

Drives: 2016 BMW 528 (F10)
Join Date: Sep 2018
Location: CA

iTrader: (0)

Thanks Bruno112.
I tried those setting, but it did not help...I couldn't actually tell if they did anything. Just to clarify, I can read and listen to message I receive, but when I try to dictate a reply, it tells me that the car needs to parked.
Appreciate 0
      09-19-2018, 11:39 AM   #335
Bruno112
Private
Croatia
11
Rep
91
Posts

Drives: 2014 F10 530d MSport
Join Date: Aug 2013
Location: Croatia

iTrader: (0)

Quote:
Originally Posted by ZaphodB View Post
Thanks Bruno112.
I tried those setting, but it did not help...I couldn't actually tell if they did anything. Just to clarify, I can read and listen to message I receive, but when I try to dictate a reply, it tells me that the car needs to parked.
Hmm,maybe try this with video in motion in same HU_NBT modul.
DVD-in-Motion activated:
3000  SPEEDLOCK_X_KMH_MAX Change werte to: FF
3000  SPEEDLOCK_X_KMH_MIN Change werte to: FF
3000  VIDEO_HANDBRAKE set to: nicht_aktiv
3000  VIDEO_FRONT_LOCKED set to: nicht_aktiv
3000  VIDEO_SPEEDLOCK_CONDITION set to: none=00


Disable Legal Disclaimers
3001LEGAL_DISCLAIMER_TIME set to: kein_ld
3001MACRO_CAM_LEGALDISCLAIMER set to: kein_ld
3001MACRO_NVICAM_LDISCLAIMER set to: kein_ld
Appreciate 0
      09-20-2018, 02:43 AM   #336
et7007
New Member
0
Rep
5
Posts

Drives: F10
Join Date: Sep 2018
Location: LATVIA

iTrader: (0)

Hi,
(I am new on this forum)
Just bought the cable and got the links to E-sys (E-Sys_Setup-3.27.1_RC_b44813), ESysLauncherPremiumSetup_2.7.1_Build_135 and v63.4_PSdZData_Lite but I can not get the ESys Launcher working.
In the installation instructions its said - E-sys Launcher Premium to stop working after 30/12/2017. - To work around use Launcher ReArm and change the PC date back to April 2017. Followed the instructions but couldn't get it working. Am I going the right way or do I need another Launcher version?
Thanks!
Appreciate 0
      09-20-2018, 06:22 AM   #337
shawnsheridan
Lieutenant General
shawnsheridan's Avatar
United_States
3189
Rep
17,401
Posts

Drives: 2016 650i GC M-Sport
Join Date: Feb 2010
Location: Houston, TX

iTrader: (0)

Garage List
Quote:
Originally Posted by et7007 View Post
Hi,
(I am new on this forum)
Just bought the cable and got the links to E-sys (E-Sys_Setup-3.27.1_RC_b44813), ESysLauncherPremiumSetup_2.7.1_Build_135 and v63.4_PSdZData_Lite but I can not get the ESys Launcher working.
In the installation instructions its said - E-sys Launcher Premium to stop working after 30/12/2017. - To work around use Launcher ReArm and change the PC date back to April 2017. Followed the instructions but couldn't get it working. Am I going the right way or do I need another Launcher version?
Thanks!
You need to be using Launcher PREMIUM 2.8.2., which is good until the end of 2018.

TM built in Date Manipulation protection in newer Launcher, and that is why you have this problem. Only solution I have seen that works is a fresh install of Windows. Good luck with it.
__________________

2016 650i GC M-Sport w/ 20" 373M Wheels; Alpine White; Individual Opal White Full Merino Leather; Gray Poplar Wood Trim
Anthracite Alcantara Headliner; Ceramic Controls; Executive Package w/ B&O Sound System; Integral Active Steering, etc.
Appreciate 0
      09-23-2018, 12:16 AM   #338
et7007
New Member
0
Rep
5
Posts

Drives: F10
Join Date: Sep 2018
Location: LATVIA

iTrader: (0)

Thanks Shawn.
I gave it a try but turned out that launcher didnt install on virtualbox windows on my mac
I need to find a spare laptop for fresh windows
Appreciate 0
      10-03-2018, 03:20 PM   #339
OrcaPod
New Member
2
Rep
23
Posts

Drives: 2011 BMW 528i
Join Date: Sep 2018
Location: Toronto, Canada

iTrader: (0)

Hi Shawn,
Can you please send me link for the software (my car is 2011 bmw 528i)
Thanks in advance
Appreciate 0
      10-03-2018, 03:46 PM   #340
shawnsheridan
Lieutenant General
shawnsheridan's Avatar
United_States
3189
Rep
17,401
Posts

Drives: 2016 650i GC M-Sport
Join Date: Feb 2010
Location: Houston, TX

iTrader: (0)

Garage List
Quote:
Originally Posted by OrcaPod View Post
Hi Shawn,
Can you please send me link for the software (my car is 2011 bmw 528i)
Thanks in advance
PM sent.
__________________

2016 650i GC M-Sport w/ 20" 373M Wheels; Alpine White; Individual Opal White Full Merino Leather; Gray Poplar Wood Trim
Anthracite Alcantara Headliner; Ceramic Controls; Executive Package w/ B&O Sound System; Integral Active Steering, etc.
Appreciate 0
      10-12-2018, 03:07 PM   #341
ciscospirit
New Member
Austria
0
Rep
17
Posts

Drives: BMW 640d xDrive GC (F06)
Join Date: Jan 2018
Location: Graz

iTrader: (0)

Hello,

i have a F06 from year 2015 with a S302 Alarm System.
i coded a bit arround to enable headlight and highbeam flashing if alarm is triggered, but it doesn't work.

i tried to change this from nicht_aktiv to aktiv:

FZD > 3002 DWA:
Optische Alarmausgabe Fernlight = aktiv
Optische Alarmausgabe Abblendlicht = aktiv

if i trigger the alarmsystem, my flashing lights start flashing and the alarm signal chime, but no headlights or high beam...

did i miss something?
Any idea if i had to enable something else somewhere?

At first I thought it might be because it was daytime, but i also tried it at night and the lights still have not flashed.

hm :/

Last but not least: can you tell me, how i can increase the duration time of the alarm signal chime to 2 minutes or more?
i think it should be done with this settings, but i am not sure about and also not which value will be the right setting for duration time.

FZD > 3001:
- Alarm duration time with external supply
- alarm duration time in self-powering mode
- alarm pause duration
- duty cycle

It would be very nice if you could help me
Appreciate 0
      10-14-2018, 07:23 PM   #342
Almaretto
Major General
Almaretto's Avatar
United_States
1552
Rep
6,929
Posts

Drives: Coded '16 F10/F15 MSport
Join Date: Dec 2015
Location: Mountain View, CA

iTrader: (0)

Quote:
Originally Posted by ciscospirit View Post
Hello,

i have a F06 from year 2015 with a S302 Alarm System.
i coded a bit arround to enable headlight and highbeam flashing if alarm is triggered, but it doesn't work.

i tried to change this from nicht_aktiv to aktiv:

FZD > 3002 DWA:
Optische Alarmausgabe Fernlight = aktiv
Optische Alarmausgabe Abblendlicht = aktiv

if i trigger the alarmsystem, my flashing lights start flashing and the alarm signal chime, but no headlights or high beam...

did i miss something?
Any idea if i had to enable something else somewhere?

At first I thought it might be because it was daytime, but i also tried it at night and the lights still have not flashed.
Did you check light modules (FLE or TMS/LHM)?
Appreciate 0
      10-23-2018, 05:24 PM   #343
ciscospirit
New Member
Austria
0
Rep
17
Posts

Drives: BMW 640d xDrive GC (F06)
Join Date: Jan 2018
Location: Graz

iTrader: (0)

Quote:
Originally Posted by Almaretto View Post
Did you check light modules (FLE or TMS/LHM)?
Hello,

thanks for the hint... hmm no i didn't check them.
do you have some more detailed information what excactly i could search for?

thanks again
Appreciate 0
      10-23-2018, 05:26 PM   #344
ciscospirit
New Member
Austria
0
Rep
17
Posts

Drives: BMW 640d xDrive GC (F06)
Join Date: Jan 2018
Location: Graz

iTrader: (0)

btw: can you help me also with that:

how can I increase the duration time of the alarm signal chime to 2 minutes?
i think it should be done with this settings, but i am not sure about and also not which value will be the right setting for duration time.

FZD > 3001:
- Alarm duration time with external supply
- alarm duration time in self-powering mode
- alarm pause duration
- duty cycle
Appreciate 0
      10-23-2018, 06:42 PM   #345
Almaretto
Major General
Almaretto's Avatar
United_States
1552
Rep
6,929
Posts

Drives: Coded '16 F10/F15 MSport
Join Date: Dec 2015
Location: Mountain View, CA

iTrader: (0)

Quote:
Originally Posted by ciscospirit View Post
Hello,

thanks for the hint... hmm no i didn't check them.
do you have some more detailed information what excactly i could search for?

thanks again
No. There are various parameters in each that refer to functionality. It will depend on which hardware vehicle has.

No...I have never messed with duration, so I cannot help.
Appreciate 0
      10-24-2018, 05:37 AM   #346
aladinn006
Registered
0
Rep
1
Posts

Drives: Bmw f10 520d
Join Date: Oct 2018
Location: Coventry

iTrader: (0)

Hi everyone i love my bmw , my bmw loves me
I wish to do some diy and coding and whould be helpfull some tips from you guys
Appreciate 0
      10-26-2018, 09:03 AM   #347
ciscospirit
New Member
Austria
0
Rep
17
Posts

Drives: BMW 640d xDrive GC (F06)
Join Date: Jan 2018
Location: Graz

iTrader: (0)

Quote:
Originally Posted by Almaretto View Post
No. There are various parameters in each that refer to functionality. It will depend on which hardware vehicle has.

No...I have never messed with duration, so I cannot help.
Hello Almaretto,

i checked my CAFD Files and can just found "FLE" but not "TMS" or "LHM".
in "FLE" i found something like:

PANICMODE_Idx => 02_Value
RAIDALARM_Idx => F010Wert_SA552_ECE_LA_LL
LWR_Offsets_B_PANICMODE => 01_Value
LWR_Offsets_B_RAIDALARM => 01_Value


but i have no idea, what i should change here to get my lights working if alarm is activated.
Appreciate 0
      10-28-2018, 10:08 AM   #348
Gixxer550i
Enlisted Member
2
Rep
40
Posts

Drives: 2015 550i
Join Date: Apr 2018
Location: New York

iTrader: (1)

Last time I coded I used the cheat sheet And manually changed some codes. Has things changed recently? Also where can I get the latest files? When were they last updated?

Another issue is my with parking assist. Not sure if this is a coding issue. When I initially put the car in drive from initially starting up the car the parking Assist does not detect anything unless I put it in reverse. Not even sure if this is a thing. Any help would be nice. Thanks.
Appreciate 0
      10-31-2018, 12:06 AM   #349
dzz
New Member
2
Rep
23
Posts

Drives: 2015 BMW 535xi
Join Date: Sep 2018
Location: Virginia

iTrader: (0)

Garage List
2015 BMW  [0.00]
link to E-sys software

Shawn,

can you please send me the link to E-sys software. I have 2015 535xi M-sport
Appreciate 0
      10-31-2018, 12:15 AM   #350
shawnsheridan
Lieutenant General
shawnsheridan's Avatar
United_States
3189
Rep
17,401
Posts

Drives: 2016 650i GC M-Sport
Join Date: Feb 2010
Location: Houston, TX

iTrader: (0)

Garage List
Quote:
Originally Posted by dzz View Post
Shawn,

can you please send me the link to E-sys software. I have 2015 535xi M-sport
PM sent.
__________________

2016 650i GC M-Sport w/ 20" 373M Wheels; Alpine White; Individual Opal White Full Merino Leather; Gray Poplar Wood Trim
Anthracite Alcantara Headliner; Ceramic Controls; Executive Package w/ B&O Sound System; Integral Active Steering, etc.
Appreciate 0
      10-31-2018, 10:14 PM   #351
dzz
New Member
2
Rep
23
Posts

Drives: 2015 BMW 535xi
Join Date: Sep 2018
Location: Virginia

iTrader: (0)

Garage List
2015 BMW  [0.00]
I cannot install ESysLauncherPremiumSetup_2.8.2_Build_155.msi in the virtual machine. Can E-sys be run under the Vmware Fusion, Win 10 on a Mac? Please see attached image for the message that I get
Attached Images
 
Appreciate 0
      10-31-2018, 10:25 PM   #352
Almaretto
Major General
Almaretto's Avatar
United_States
1552
Rep
6,929
Posts

Drives: Coded '16 F10/F15 MSport
Join Date: Dec 2015
Location: Mountain View, CA

iTrader: (0)

Quote:
Originally Posted by dzz View Post
I cannot install ESysLauncherPremiumSetup_2.8.2_Build_155.msi in the virtual machine. Can E-sys be run under the Vmware Fusion, Win 10 on a Mac? Please see attached image for the message that I get
E-sys can be run in VM. Launcher cannot. It will work in Bootcamp.
Appreciate 0
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 09:11 PM.




5post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST