2010 2011 BMW 5 Series Forum F10
BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read
 

2010 2011 BMW 5 Series Forum F10 BMW 5-Series (F10) Forums General 5-Series Sedan and Wagon (F10 / F11) Forum 2011 535xi GT N55 - ISTA 1C3102 oil pressure sensor too low before engine start
Post Reply
 
Thread Tools Search this Thread
      01-28-2024, 10:50 PM   #1
iverson03tj
New Member
2
Rep
8
Posts

Drives: e39 M5, F07 535gt xD
Join Date: Jan 2024
Location: Canada

iTrader: (0)

2011 535xi GT N55 - ISTA 1C3102 oil pressure sensor too low before engine start

Hey yall. I could really use your help with troubleshooting this one. Just bought this car with 174k km and fixed a few things listed below.

Got this code on ISTA. 1C3102 - Engine-oil pressure sensor, plausbility : Pressure too low before engine start

- Replaced the Oil Pressure sensor
- Replaced, ignition coils, spark plugs, oil filter & cooler housing gasket, belt tensioner and both pulleys.
- changed the oil filter cap to a URO metal one with a metal inner filter. (I heard that this can cause the oil pressure code, so will try to change it back to the plastic oil filter cap tomorrow)
- reset adaptation ran well but a slight hesitation
- I did the priming procedure and coolant purge procedure

Details:
Oil temp 102c - 105c
Oil pressure at Idle = 1600 hPa / 1.6 Bars / 23 psi
oil pressure during driving = is 4k hPa @ 1600 RPM to around 7k hPa @6k RPM
Appreciate 1
      01-29-2024, 09:41 AM   #2
iverson03tj
New Member
2
Rep
8
Posts

Drives: e39 M5, F07 535gt xD
Join Date: Jan 2024
Location: Canada

iTrader: (0)

On another note:

the Previous owner somehow stripped the oil pan drain plug -_-

So i am installing a Helicoil to it.

RealOEM.com It shows the drain plug as M12x16

Does the 16 stand for 16mm and does it mean its 16mm in height of the entire bolt or just the thread?


I googled it and it says that the drain plug is M12 x1.5 thread
Appreciate 0
      01-29-2024, 10:10 AM   #3
iverson03tj
New Member
2
Rep
8
Posts

Drives: e39 M5, F07 535gt xD
Join Date: Jan 2024
Location: Canada

iTrader: (0)

Ref: oil filter cap to a URO metal one with a metal inner filter.
This is the one i used
https://www.ecstuning.com/b-uro-prem...27525334prm~u/
Appreciate 0
      01-29-2024, 05:32 PM   #4
Conserve
Private First Class
183
Rep
127
Posts

Drives: 1976 BMW 2002 & 2015 BMW535i
Join Date: Sep 2023
Location: Ohio

iTrader: (0)

1). 16mm is length of threads. full specs Oil Drain Plug With (12 X 1.5 X 16 mm)
2). Throw that URO oil filter cap with a metal inner filter in neighbor's pool and go back to original. You and your engine will be lot happier.
Appreciate 2
      02-17-2024, 09:00 AM   #5
iverson03tj
New Member
2
Rep
8
Posts

Drives: e39 M5, F07 535gt xD
Join Date: Jan 2024
Location: Canada

iTrader: (0)

Quote:
Originally Posted by Conserve View Post
1). 16mm is length of threads. full specs Oil Drain Plug With (12 X 1.5 X 16 mm)
2). Throw that URO oil filter cap with a metal inner filter in neighbor's pool and go back to original. You and your engine will be lot happier.
Thank you for the suggestion, I swapped the oil filter cap back to stock, still the same issue exists.
Appreciate 0
      02-17-2024, 10:22 AM   #6
Conserve
Private First Class
183
Rep
127
Posts

Drives: 1976 BMW 2002 & 2015 BMW535i
Join Date: Sep 2023
Location: Ohio

iTrader: (0)

In OP you said changed oil filter cap & metal inner filter. Last post swapped the oil filter cap back to stock. If I follow you correctly you must of remove that center piece of cap and installed just the cap? How about replacing inner filter unit back to stock?
Attached Images
 

Last edited by Conserve; 02-17-2024 at 10:36 AM..
Appreciate 0
      02-17-2024, 11:00 AM   #7
iverson03tj
New Member
2
Rep
8
Posts

Drives: e39 M5, F07 535gt xD
Join Date: Jan 2024
Location: Canada

iTrader: (0)

Quote:
Originally Posted by Conserve View Post
In OP you said changed oil filter cap & metal inner filter. Last post swapped the oil filter cap back to stock. If I follow you correctly you must of remove that center piece of cap and installed just the cap? How about replacing inner filter unit back to stock?
I replaced the inner filter as well.
Also while combing through ISTA, I see there is some sort of oil pressure control valve. No 11

https://www.realoem.com/bmw/enUS/sho...diagId=11_4447

https://www.fcpeuro.com/products/bmw...ve-11417622768

Could this be the reason why the oil pressure isn't high at start up?
Appreciate 0
      02-17-2024, 03:50 PM   #8
Conserve
Private First Class
183
Rep
127
Posts

Drives: 1976 BMW 2002 & 2015 BMW535i
Join Date: Sep 2023
Location: Ohio

iTrader: (0)

You maybe on into something.

https://f10.5post.com/forums/showthread.php?t=1937902

Appreciate 0
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 04:19 PM.




5post
Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2024, vBulletin Solutions Inc.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST