2010 2011 BMW 5 Series Forum F10
BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read
 

2010 2011 BMW 5 Series Forum F10 BMW 5-Series Gran Turismo GT (F07) Forums General 5-Series GT (Gran Turismo) (F07) Forum Defa charger/coolant heater killing my battery
Post Reply
 
Thread Tools Search this Thread
      01-28-2023, 09:35 PM   #1
Newfeebullet
New Member
0
Rep
10
Posts

Drives: BMW 535gt xdrive
Join Date: Aug 2022
Location: Canada

iTrader: (0)

Defa charger/coolant heater killing my battery

Anyone come across this? 2011 535 gt had the defa 5899 installed a couple years back. I was always iffy it was working or not and found out this summer while doing some of my own work it was never connected properly and the ground wire was hanging never been grounded to the car.

Brought it in they replaced the module cause they said it was fried and said they arenít installing these anymore, Iím guessing because of issues, now when I plug it in it kills my battery.
Will call again on Monday but figured Iíd do some digging myself over the weekend.
Appreciate 0
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 05:19 AM.




5post
Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2023, vBulletin Solutions Inc.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST