2010 2011 BMW 5 Series Forum F10
BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read
 

2010 2011 BMW 5 Series Forum F10 BMW 5-Series (F10) Forums Regional Forums UK 2016 520d F10 hesitation
Post Reply
 
Thread Tools Search this Thread
      04-16-2024, 04:15 PM   #1
Wahno
Registered
0
Rep
2
Posts

Drives: BMW 520d f10
Join Date: Apr 2024
Location: Ireland

iTrader: (0)

2016 520d F10 hesitation

Serviced my 2016 520d on Sunday morning, everything as normal, it got new air filter (not sure if itís important but the old one was very bad) new oil filter and an oil change, about 2 hours of driving after the service I started to notice a hesitation on cruise control, I canít put my finger on when particularly it happens it seems to be random, itís more noticeable on the motorway regardless of cruise control or not (but doesnít happen when driving like an f1 driver) it seems to happen more at slow speeds

I tried topping up with premium fuel as I thought that might be a problem

Iíve tried the throttle body adaptation reset not sure if it worked itís kinda hard to tell

The only error I have is when engagement of reverse I get a parking sensor error which Iím Trying to get ordered up but my parts man isnít replying🤦🏻‍♂️,

Iíll be adjusting tyre pressure tomorrow there is a couple of psi in the difference of the back tyres but I donít imagine that would be enough to make a difference
Appreciate 0
      05-04-2024, 01:35 PM   #2
dennis3258
New Member
2
Rep
16
Posts

Drives: BMW F10 520D
Join Date: Apr 2021
Location: Bangor, Northern Ireland

iTrader: (0)

Garage List
Hi, just wondering, is the issue solved or still some "hesitation" with the car driving?
The things I can think of is, when was the last time the diesel filter was changed, did you have a high quality air filter, did you clean the filter body/air intake out with hoover before you put the new air filter in place.
Did you use the correct full synthetic oil?
At the moment I can't think of any other question, but these would be the standard questions.
Appreciate 0
      05-05-2024, 02:04 PM   #3
Wahno
Registered
0
Rep
2
Posts

Drives: BMW 520d f10
Join Date: Apr 2024
Location: Ireland

iTrader: (0)

I found the issue in the end, Iím fairly handy with things myself but I honestly tried to eliminate everything, I brought the car to the a bmw specialist, he scanned it and done some tests and everything was working fine, I arrived to pick up the car and he had asked what air filter I was using, I opened it up to show him and plot twist it wasnít that😂 ended up noticing that bmw had broken the air intake pipe for the turbo and the vaccume pipe beside it, while doing the egr cooler, luck was on my side I suppose, havenít managed to get a part number for it yet but itís pushed back on and working fine at the moment but I am going to change it for a permanent fix
Appreciate 0
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 01:23 AM.




5post
Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2024, vBulletin Solutions Inc.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST