2010 2011 BMW 5 Series Forum F10
BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read
 

2010 2011 BMW 5 Series Forum F10 BMW 5-Series (F10) Forums Regional Forums USA - NY/NJ/PA/CT Car pulls right after alignment 2015 535i xdrive
Post Reply
 
Thread Tools Search this Thread
      09-06-2020, 12:37 AM   #1
jbatt89
New Member
0
Rep
6
Posts

Drives: 2015 535i xdrive
Join Date: Nov 2018
Location: PA

iTrader: (0)

Car pulls right after alignment 2015 535i xdrive

My car started pulling right after I hit a break in the road, not a pothole, but the road was actually elevated at the joint. My car now pulls to the right as soon as I let go of the wheel- city or highway driving. I took it to the dealer and after a week aligning it, swapping tires, etc. they could not figure out the problem. They called me and said my car is within spec but still pulls to the right - sounded odd to me. I asked them how will I know if the car needs an alignment or is ďjust pullingĒ. They told me Iíll see uneven tire wear. This hardly seems like a sound strategy. Iím not sure what the next step should be but canít say Iím confident with the way things are now. Any suggestions?
Appreciate 0
      09-06-2020, 10:54 PM   #2
Unspec
Lieutenant Colonel
Unspec's Avatar
United_States
718
Rep
1,994
Posts

Drives: 2015 BMW 535xi
Join Date: Apr 2019
Location: New Jersey

iTrader: (0)

Car still pulls to the right if you swap the right and left side wheels?
__________________
2015 BMW 535xi
Bootmod3 Stage 2 | ER charge pipe | ER Catted DP | Remus Exhaust | Gplus FMIC | KW V3 | Turner Monoball thrust arm bushings | Wallet regrets
ISTA VM Setup/Tutorial
Appreciate 0
      09-07-2020, 09:43 AM   #3
jbatt89
New Member
0
Rep
6
Posts

Drives: 2015 535i xdrive
Join Date: Nov 2018
Location: PA

iTrader: (0)

Yes, the dealer said they swapped wheels and put on a set from another car.
Appreciate 0
      10-01-2020, 05:20 PM   #4
Trainwreck914
Lieutenant
Trainwreck914's Avatar
United_States
102
Rep
401
Posts

Drives: BMW F10 F15 E39 E90 E53
Join Date: Dec 2019
Location: NY CT

iTrader: (0)

Might have bent the subframe
Ask me how I know...
Appreciate 0
Post Reply

Bookmarks

Tags
alignment issue

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 06:38 AM.




5post
Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2021, vBulletin Solutions Inc.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST