2010 2011 BMW 5 Series Forum F10
BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read
 

2010 2011 BMW 5 Series Forum F10 F10 Technical Topics DIY Guides & Discussions HELP! 2012 BMW 528i N20 - P1339 Camshaft Position Sensor
Post Reply
 
Thread Tools Search this Thread
      11-14-2020, 11:31 PM   #1
jbahr
Registered
0
Rep
1
Posts

Drives: 2012 BMW 528i
Join Date: Nov 2020
Location: CA

iTrader: (0)

HELP! 2012 BMW 528i N20 - P1339 Camshaft Position Sensor

Hello,

My car recently stopped working on me. Out of nowhere, it wouldnt start and check engine came on.
I got a buddy of mine to read the code and i got P1339 - "Camshaft Position Sensor 'B' Faulty Phase Position (Bank 1)".

I changed the camshaft position sensors and nothing changed. I also tried to start it with starter fluid but no change. The car cranks and the battery is getting 12v. The fuel pressure is good and the spark plug is good.

What else can I attempt to do?

The car will crank for ever and ever and not start.

Anything helps. Thank you.
Appreciate 0
      12-08-2020, 01:13 PM   #2
judexromo
Registered
0
Rep
1
Posts

Drives: 2012 BMW 528i xdrive
Join Date: Sep 2016
Location: MD

iTrader: (0)

Same issue

We have the same issue with the same engine/year! I finally found someone with the same issue online.

I replaced the 2 CP sensors, even swapped them with no help. Replaced the Crankshaft sensor(near the starter) with no help. Replaced the Tensioner and Serpentine Belt(due already) with no help.

I see an oil leak in the valve cover, I will replace the gasket next.

My timing belt is loose, which I suspect to be the culprit, but I will found out once I remove the valve cover. FCP Euro told me to check the Valvetronic eccentric shaft actuator which can cause electrical issues.

Engine runs but sluggish.

Any update on your P1339 issue. Let's help each other.
Appreciate 0
      01-04-2021, 12:42 AM   #3
Handsomecore
Private
United_States
24
Rep
61
Posts

Drives: 2007 328i sedan
Join Date: Apr 2013
Location: Bronx ny

iTrader: (0)

Do you have guys have a bmw scanner ? I had this problem with a customers car and it was the VVT motor . Car was a 2015 528 n20 motor. car was cranking but it was a low compression crank if know that sound
Appreciate 0
      11-07-2021, 10:46 PM   #4
azguy83
New Member
0
Rep
5
Posts

Drives: BMW 528i 2013 / X5 35i 2017
Join Date: Feb 2013
Location: Tulsa, OK

iTrader: (0)

Any updates on this p1339 issue?
I have a 2013 528i and has this code and just cranks and cranks and doesn’t start.
I changed the crankshaft sensor and camshaft sensors and still same…
Appreciate 0
      11-09-2021, 11:42 AM   #5
Unspec
Colonel
Unspec's Avatar
United_States
768
Rep
2,111
Posts

Drives: 2015 BMW 535xi
Join Date: Apr 2019
Location: New Jersey

iTrader: (0)

Given that it's a N20, my money is on engine jumping timing.
__________________
2015 BMW 535xi
Bootmod3 Stage 2 | ER charge pipe | ER Catted DP | Remus Exhaust | Gplus FMIC | KW V3 | Turner Monoball thrust arm bushings | Wallet regrets
ISTA VM Setup/Tutorial
Appreciate 0
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 12:58 PM.




5post
Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2022, vBulletin Solutions Inc.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST