2010 2011 BMW 5 Series Forum F10
BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read
 

2010 2011 BMW 5 Series Forum F10 F10 Technical Topics Navigation, iDrive, Audio, Video, Bluetooth, Phone, Coding Bluetooth having issues playing audio
Post Reply
 
Thread Tools Search this Thread
      02-25-2021, 01:49 PM   #1
ramman434
Lieutenant
United_States
710
Rep
538
Posts

Drives: F30 335i
Join Date: Dec 2012
Location: Fort Lauderdale, FL

iTrader: (0)

Bluetooth having issues playing audio

So this started back on Monday in my 2016 F10. My Bluetooth will show not connected to my iPhone Xs (14.4 iOS) on the car, yet the phone shows connected to the car. I'm able to send/receive phone calls/texts.

However, I have no audio playback for music, podcasts, etc. When I click on the media menu, it won't show there's any phone connected to Bluetooth.

I connect via my lightning cable, and sometimes it does the same thing, not registering that there's a phone directly connected to the car.

Do I have a module going out or something?

Anyone else have issue with this? Really annoying since I just started getting into podcasts & listen on my commute. I've literally restarted the car in traffic to get this working properly.
__________________
'07 Montego Blue/Saddle Brown E92 335i - 6spd. - SOLD
'16 Carbon Black Metallic F10 535i M-Sport - TOTALED 11/21/21
'13 Black Sapphire Metallic F30 335i M-Sport - unknown charge pipe, MSport Exhaust, 20" 405M wheels, $61k MSRP, CF M4 Mirror caps & Spoiler, NGK plugs, Dinan Coils, BMS intake
Appreciate 0
      02-25-2021, 06:44 PM   #2
walmark
Apprentice
walmark's Avatar
82
Rep
490
Posts

Drives: 550i F10 '15
Join Date: Feb 2013
Location: SF Bay

iTrader: (2)

It happened to me over the last month (iPhone 8+), but last Thursday I deleted my phone from the car and paired it again from scratch and the issue went away. My guess is iOS update screwed something up.
Appreciate 0
      02-26-2021, 08:48 AM   #3
ramman434
Lieutenant
United_States
710
Rep
538
Posts

Drives: F30 335i
Join Date: Dec 2012
Location: Fort Lauderdale, FL

iTrader: (0)

See I did that too, and it started happening again almost immediately
__________________
'07 Montego Blue/Saddle Brown E92 335i - 6spd. - SOLD
'16 Carbon Black Metallic F10 535i M-Sport - TOTALED 11/21/21
'13 Black Sapphire Metallic F30 335i M-Sport - unknown charge pipe, MSport Exhaust, 20" 405M wheels, $61k MSRP, CF M4 Mirror caps & Spoiler, NGK plugs, Dinan Coils, BMS intake
Appreciate 0
      02-26-2021, 12:32 PM   #4
Matt338
Private First Class
39
Rep
113
Posts

Drives: 2016 535i M Sport
Join Date: Jan 2016
Location: Delray Beach, FL

iTrader: (3)

I've been having a similar issue with Bluetooth. When it first connects and starts playing, the music is sped up and choppy. This goes for about 10 seconds and then it normals out. It's also been kinda skipping sometimes and not displaying metadata on the screen, just says unknown artist and unknown track. Phone calls and usb works fine. I have an iPhone 11 Pro and use Spotify. Not sure what's going on.
Appreciate 0
      08-01-2021, 12:39 PM   #5
ErnestHouse
First Lieutenant
United_States
29
Rep
379
Posts

Drives: 2014 535i GT
Join Date: Nov 2012
Location: South Florida

iTrader: (0)

I had the same problem after updating to iOS 14.
__________________
2014 535i GT M Sport Glacier, Mocha, ZDA, ZDB, ZDH, ZPP, 2VH, 416, 456, 4CK
Appreciate 0
      08-02-2021, 12:25 PM   #6
ErnestHouse
First Lieutenant
United_States
29
Rep
379
Posts

Drives: 2014 535i GT
Join Date: Nov 2012
Location: South Florida

iTrader: (0)

Quote:
Originally Posted by ErnestHouse View Post
I had the same problem after updating to iOS 14.
I updated to iOS 14.7.1 and did the following procedure I read regarding Bluetooth connectivity problems.

1) On your iDrive, Remove This Device for your phone
2) Update iOS
3) Go into phone settings and "Forget This Device" for the BMW
4) Turn off Bluetooth
5) Do a HARD RESET* on your phone

After doing this, my phone connects to BT every time. Even when I disconnect it from USB.

* On my iPhone 8 that is done by pressing and holding Volume Down, Home, Power buttons simultaneously
__________________
2014 535i GT M Sport Glacier, Mocha, ZDA, ZDB, ZDH, ZPP, 2VH, 416, 456, 4CK
Appreciate 0
      09-10-2021, 01:05 AM   #7
Jer_i_miah
New Member
Jer_i_miah's Avatar
United_States
5
Rep
7
Posts

Drives: BMW 535i
Join Date: Jun 2021
Location: Utah

iTrader: (0)

Mines been doing this for a the last few months also. I toggle backwards to the aux option, select aux, toggle back, select my phone, and then it plays. Also mine will pick it up automatically if I leave a media app open. It's so mf irritating.
Appreciate 0
      09-10-2021, 11:00 AM   #8
ramman434
Lieutenant
United_States
710
Rep
538
Posts

Drives: F30 335i
Join Date: Dec 2012
Location: Fort Lauderdale, FL

iTrader: (0)

All of a sudden, the car has been fine for my phone the last few months w/no issues.

However, my wife were on a 12hr road trip last week, with her phone plugged in, and it kept losing connection to her phone. Finally we switched her to Bluetooth and it held the connection.
__________________
'07 Montego Blue/Saddle Brown E92 335i - 6spd. - SOLD
'16 Carbon Black Metallic F10 535i M-Sport - TOTALED 11/21/21
'13 Black Sapphire Metallic F30 335i M-Sport - unknown charge pipe, MSport Exhaust, 20" 405M wheels, $61k MSRP, CF M4 Mirror caps & Spoiler, NGK plugs, Dinan Coils, BMS intake
Appreciate 0
      09-12-2021, 04:02 AM   #9
TabsTheCat
Registered
0
Rep
4
Posts

Drives: 520D
Join Date: Sep 2021
Location: uk

iTrader: (0)

I can always stream audio from an Android phone to my 2011 520D but the whole system is full of bugs. Most of the time the displayed Album and Artist is 'unknown' other times it displays the album/artist all the time.

Once it even showed a bar graph showing the progress of the track being played but that was only once.

The whole system is very unreliable in my opinion.
Appreciate 0
      09-22-2021, 04:55 PM   #10
adyjoy
New Member
2
Rep
12
Posts

Drives: BMW F10
Join Date: Sep 2021
Location: Romania

iTrader: (0)

I have a problem with my F10 bluetooth!It conect very hard..after more 5 minute
Appreciate 0
      03-19-2022, 09:11 PM   #11
yafool
Private
3
Rep
77
Posts

Drives: 2011 335d
Join Date: Jan 2013
Location: Los Angeles

iTrader: (0)

Anyone have a solution to these bluetooth connectivity issues?
Appreciate 0
      10-18-2023, 11:59 PM   #12
razfrankel
Private
United_States
3
Rep
54
Posts

Drives: 2013 bmw 550i xdrive
Join Date: Oct 2023
Location: 11581

iTrader: (0)

I have a 2013 bmw 550i I play music but videos from my photo library won’t play is it the Bluetooth or the car or the phone ?
Appreciate 0
      10-20-2023, 11:58 AM   #13
rztt6
New Member
0
Rep
7
Posts

Drives: BMW 335i
Join Date: Oct 2023
Location: Ireland

iTrader: (0)

I've had intermittent issues when my Apple Watch and iPhone are both connected to my phone on an E92 with CIC retrofit. Worth disconnecting all other bluetooth devices as a test next time it happens.
Appreciate 0
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 01:44 PM.




5post
Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2024, vBulletin Solutions Inc.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST