2010 2011 BMW 5 Series Forum F10
BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read
 

2010 2011 BMW 5 Series Forum F10 F10 Technical Topics Navigation, iDrive, Audio, Video, Bluetooth, Phone, Coding Comfort Access Problem - FIXED
Post Reply
 
Thread Tools Search this Thread
      03-26-2016, 07:45 PM   #1
UA_civ_eng
Second Lieutenant
83
Rep
208
Posts

Drives: '11 550i Past:'11 E92 M3
Join Date: Nov 2012
Location: North FL

iTrader: (1)

Comfort Access Problem - FIXED

My car likes to make me wait in regards to the Comfort Access; when trying to lock and unlock with the door handles and the key in my pocket, it never works on the first try. Sometimes it's the 3rd try, sometimes it the 40th try. The problem occurs with all the doors and the trunk, and also with both keys. I also frequently get the "Remote Not Detected" message while the car is running. Anybody that can shed any light on the situation, please do so!

EDIT: Problem solved! I diagnosed the car with ISTA/D and sure enough, it showed a Comfort Access fault, specifically with the center console front antenna (or "aerial" as BMW calls it). I saw on the car's service history that the cup holder in the center console had been repaired/replaced at one point, and I assume that the tech did not hook up the antenna when reinstalling the console. Pictures below!
Attached Images
   

Last edited by UA_civ_eng; 03-29-2016 at 02:22 PM..
Appreciate 4
Kyngofpop676.50
      03-26-2016, 09:34 PM   #2
Aaron@Autosource
Aaron@Autosource's Avatar
90
Rep
305
Posts

Drives: F110/F22
Join Date: Aug 2012
Location: Socal

iTrader: (2)

If both keys produce the same problem then I would think the sensors on the car itself are either faulty(not sure how common this is, I know there are multiple ones all over the car) or there's interference from another source. Never had that issue before personally but looking into that would be my next step if it did happen with my car...
Appreciate 0
      03-26-2016, 09:47 PM   #3
UA_civ_eng
Second Lieutenant
83
Rep
208
Posts

Drives: '11 550i Past:'11 E92 M3
Join Date: Nov 2012
Location: North FL

iTrader: (1)

Quote:
Originally Posted by Aaron@Autosource View Post
If both keys produce the same problem then I would think the sensors on the car itself are either faulty(not sure how common this is, I know there are multiple ones all over the car) or there's interference from another source. Never had that issue before personally but looking into that would be my next step if it did happen with my car...
I agree, either a sensor or one of the controlling modules. I have ruled out interference. I took it to a local independent euro shop and the guys were so hesitant to dive into the problem that they didn't even let me make an appointment (maybe too much of a hassle or they are not competent). Figured I would post the problem on here to see if anybody has had a similar case in order to possibly fix it myself.

One interesting thing: At night time, when I walk up to the car with the key in my pocket, as soon as I touch the door handle, I see lights come on on the parking brake button and the emergency flasher button. Without the remote near, touching the door handle, those lights don't come on. So this tells me that the car knows that the remote is nearby and that the door handle is being touched, there is just a piece missing from the puzzle for it to send the unlock signal to the doors.
Appreciate 0
      03-27-2016, 07:43 PM   #4
pdrf10
A Man of Wisdumb...
pdrf10's Avatar
United_States
28
Rep
114
Posts

Drives: 2011 F10 550i M Sport
Join Date: Oct 2013
Location: Playa Del Rey, CA

iTrader: (0)

Just a thought: I've experienced a similar issue on several occasions, and realized the culprit was me carrying my key fob in the same hand as my iPhone. Once I separated the two, problem solved...

Is your smartphone anywhere near your key fob when Comfort Access acts up?
__________________
Appreciate 0
      03-27-2016, 08:28 PM   #5
UA_civ_eng
Second Lieutenant
83
Rep
208
Posts

Drives: '11 550i Past:'11 E92 M3
Join Date: Nov 2012
Location: North FL

iTrader: (1)

Quote:
Originally Posted by pdrf10 View Post
Just a thought: I've experienced a similar issue on several occasions, and realized the culprit was me carrying my key fob in the same hand as my iPhone. Once I separated the two, problem solved...

Is your smartphone anywhere near your key fob when Comfort Access acts up?
Nope. I have tried it every way possible, including holding the key in my hand right beside the door handle, up in the air, etc...
Appreciate 0
      03-27-2016, 11:33 PM   #6
lemetier
Plenipotentiary
lemetier's Avatar
2541
Rep
3,029
Posts

Drives: Yes
Join Date: Jul 2010
Location: Location

iTrader: (0)

Quote:
Originally Posted by UA_civ_eng
Quote:
Originally Posted by pdrf10 View Post
Just a thought: I've experienced a similar issue on several occasions, and realized the culprit was me carrying my key fob in the same hand as my iPhone. Once I separated the two, problem solved...

Is your smartphone anywhere near your key fob when Comfort Access acts up?
Nope. I have tried it every way possible, including holding the key in my hand right beside the door handle, up in the air, etc...
Something I've noticed over the years with CA...If one has large hands, the dorsal area (between the thumb and index finger) can contact the lock sensor area on the F10 handle (Fxx 6er/7er also) at the same time as the unlock motion sensor on the back side of the handle if all 4 fingers are used. I started using a two finger method and that seems to cure the car's stubborn reception since the unlock sensor is motion activated rather than contact activated like the lock area.
Appreciate 1
      03-28-2016, 08:35 AM   #7
UA_civ_eng
Second Lieutenant
83
Rep
208
Posts

Drives: '11 550i Past:'11 E92 M3
Join Date: Nov 2012
Location: North FL

iTrader: (1)

Not the problem here, unfortunately.
Appreciate 0
      03-28-2016, 10:28 AM   #8
jabbarjd
Enlisted Member
jabbarjd's Avatar
United_States
8
Rep
33
Posts

Drives: 2013 BMW 535i
Join Date: Dec 2015
Location: SATX

iTrader: (0)

Garage List
2013 BMW 535i  [0.00]
Quote:
Originally Posted by miamiten View Post
Something I've noticed over the years with CA...If one has large hands, the dorsal area (between the thumb and index finger) can contact the lock sensor area on the F10 handle (Fxx 6er/7er also) at the same time as the unlock motion sensor on the back side of the handle if all 4 fingers are used. I started using a two finger method and that seems to cure the car's stubborn reception since the unlock sensor is motion activated rather than contact activated like the lock area.
That may explain the problem I've been having. I thought it was touch sensitive like my wife's Audi. I found it marginally irritating to have to pull the handles twice just to unlock the car because the first pull would unlock, and the second pull would open the door. I'm going to try either the two finger method like you, or see if grabbing the handle from the bottom makes any difference.
__________________
2013 BMW 535i M Sport in Titanium Silver on Black -- ZDA, ZPP, ZTP; 20" BMW 464M Wheels
2016 Audi Q3 Prestige in Utopia Blue on Rock Gray - wife's
1999 BMW z3 2.3 in Space Gray on Black - (sold)
Appreciate 0
      03-28-2016, 03:01 PM   #9
Secret_Asian
Private First Class
31
Rep
113
Posts

Drives: f10 lci luxury line
Join Date: Jul 2014
Location: philly

iTrader: (0)

Ive noticed if my key is in the same pocket as my phone and even occasionally my wallet(i suspect my id card for getting into the building at work) it sometimes takes a few tries.
Appreciate 0
      03-29-2016, 01:45 AM   #10
Almaretto
Major General
Almaretto's Avatar
United_States
2151
Rep
8,152
Posts

Drives: Test Vehicles
Join Date: Dec 2015
Location: Mountain View and Los Angeles, CA

iTrader: (0)

I have had the similar issue with phones and wallets blocking signal. However, never had any issue with touching both lock and unlock. It seems more like a sensor issue if you are holding both keys in hands. I would doubt it is a battery issue as well.
Appreciate 0
      03-29-2016, 09:40 AM   #11
UA_civ_eng
Second Lieutenant
83
Rep
208
Posts

Drives: '11 550i Past:'11 E92 M3
Join Date: Nov 2012
Location: North FL

iTrader: (1)

I am going to attempt to diagnose the problem here in an hour or so with ISTA/D.
Appreciate 0
      03-29-2016, 02:45 PM   #12
UA_civ_eng
Second Lieutenant
83
Rep
208
Posts

Drives: '11 550i Past:'11 E92 M3
Join Date: Nov 2012
Location: North FL

iTrader: (1)

Problem solved. Edited first post with fix
Appreciate 0
      03-29-2016, 02:55 PM   #13
Aaron@Autosource
Aaron@Autosource's Avatar
90
Rep
305
Posts

Drives: F110/F22
Join Date: Aug 2012
Location: Socal

iTrader: (2)

Wow, that was fast, thanks for the info as well
Appreciate 1
      03-29-2016, 06:50 PM   #14
Almaretto
Major General
Almaretto's Avatar
United_States
2151
Rep
8,152
Posts

Drives: Test Vehicles
Join Date: Dec 2015
Location: Mountain View and Los Angeles, CA

iTrader: (0)

Good work and solid write-up for other that may face issue now or the future.
Appreciate 1
      04-16-2016, 09:49 PM   #15
EL Jeffe 5
Major
EL Jeffe 5's Avatar
United_States
574
Rep
1,207
Posts

Drives: CBR1000RR
Join Date: Aug 2015
Location: Iowa

iTrader: (0)

Thanks for posting this is good fix
Appreciate 0
      05-29-2017, 09:59 AM   #16
Alexbartman
Registered
0
Rep
1
Posts

Drives: Bmw 525d (F10) 2012
Join Date: May 2017
Location: London, U.K.

iTrader: (0)

Help-CA

Sorry to drag up and oldish thread but I have a very odd CA problem...the two front doors will not lock using the ridges on the handle, but both rear doors work just fine...where exactly is the antenna...you say under the centre console, but could you be a bit more specific for me please...is it under the trim that houses the gear lever and other buttons or inside/underneath the centre armrest cubby?? I'm hoping it's just a loose connection or a faulty antenna because I tried a new handle and that didn't sort the problem at all...weirdly, it does work very sporadically...reckon I should look at the antenna...but realoem seems to show there's a different antenna for each door (so four the doors and a 5th for the trunk/boot)....I'm really confused...if I pull the front handle, the door does UNlock but it's not Miron sensing, more mechanical the the back Doris that open when I first slip my hand behind the handle without even pulling it...
Appreciate 0
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 04:10 AM.




5post
Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2022, vBulletin Solutions Inc.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST